gst1-plugins-ugly: update to 1.12.4
Signed-off-by: W. Michael Petullo <mike@flyn.org>
This commit is contained in:
parent
59c979d595
commit
b2efd6f9b9
4 changed files with 36 additions and 30 deletions
|
@ -8,7 +8,7 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=gst1-plugins-ugly
|
PKG_NAME:=gst1-plugins-ugly
|
||||||
PKG_VERSION:=1.10.5
|
PKG_VERSION:=1.12.4
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org> \
|
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org> \
|
||||||
|
@ -20,12 +20,12 @@ PKG_LICENSE_FILES:=COPYING
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/gst-plugins-ugly-$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(BUILD_DIR)/gst-plugins-ugly-$(PKG_VERSION)
|
||||||
PKG_SOURCE:=gst-plugins-ugly-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=gst-plugins-ugly-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gst-plugins-ugly/
|
PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gst-plugins-ugly/
|
||||||
PKG_HASH:=d6edc046350809c967f5b058c5c2e534d99d1d69fe1b26acd849e87781a7d7fc
|
PKG_HASH:=1c165b8d888ed350acd8e6ac9f6fe06508e6fcc0a3afc6ccc9fbeb30df9be522
|
||||||
|
|
||||||
PKG_CONFIG_DEPENDS:= \
|
PKG_CONFIG_DEPENDS:= \
|
||||||
CONFIG_PACKAGE_gst1-mod-asf \
|
CONFIG_PACKAGE_gst1-mod-asf \
|
||||||
CONFIG_PACKAGE_gst1-mod-lame \
|
CONFIG_PACKAGE_gst1-mod-lame \
|
||||||
CONFIG_PACKAGE_gst1-mod-mad \
|
CONFIG_PACKAGE_gst1-mod-mpg123 \
|
||||||
CONFIG_PACKAGE_gst1-mod-mpeg2dec \
|
CONFIG_PACKAGE_gst1-mod-mpeg2dec \
|
||||||
|
|
||||||
PKG_FIXUP:=autoreconf
|
PKG_FIXUP:=autoreconf
|
||||||
|
@ -109,7 +109,7 @@ CONFIGURE_ARGS += \
|
||||||
--disable-dvdsub \
|
--disable-dvdsub \
|
||||||
--disable-iec958 \
|
--disable-iec958 \
|
||||||
$(call GST_COND_SELECT,lame) \
|
$(call GST_COND_SELECT,lame) \
|
||||||
$(call GST_COND_SELECT,mad) \
|
$(call GST_COND_SELECT,mpg123) \
|
||||||
$(call GST_COND_SELECT,mpeg2dec) \
|
$(call GST_COND_SELECT,mpeg2dec) \
|
||||||
--disable-mpegaudioparse \
|
--disable-mpegaudioparse \
|
||||||
--disable-mpegstream \
|
--disable-mpegstream \
|
||||||
|
@ -169,7 +169,7 @@ endef
|
||||||
|
|
||||||
$(eval $(call GstBuildPlugin,asf,ASF demuxer,audio video riff rtp rtsp sdp tag,,))
|
$(eval $(call GstBuildPlugin,asf,ASF demuxer,audio video riff rtp rtsp sdp tag,,))
|
||||||
$(eval $(call GstBuildPlugin,lame,MP3 encoder (using LAME),audio,,+lame-lib))
|
$(eval $(call GstBuildPlugin,lame,MP3 encoder (using LAME),audio,,+lame-lib))
|
||||||
$(eval $(call GstBuildPlugin,mad,MP3 decoder (using MAD),audio tag,,+libid3tag +libmad))
|
$(eval $(call GstBuildPlugin,mpg123,MP3 decoder (using mpg123),audio tag,,+libid3tag +mpg123))
|
||||||
$(eval $(call GstBuildPlugin,mpeg2dec,MPEG decoder,video,,+libmpeg2))
|
$(eval $(call GstBuildPlugin,mpeg2dec,MPEG decoder,video,,+libmpeg2))
|
||||||
|
|
||||||
$(eval $(call BuildPackage,gstreamer1-plugins-ugly))
|
$(eval $(call BuildPackage,gstreamer1-plugins-ugly))
|
||||||
|
|
|
@ -1,15 +1,17 @@
|
||||||
--- a/configure.ac
|
diff -u --recursive gst-plugins-ugly-1.12.4-vanilla/configure.ac gst-plugins-ugly-1.12.4/configure.ac
|
||||||
+++ b/configure.ac
|
--- gst-plugins-ugly-1.12.4-vanilla/configure.ac 2018-02-11 20:18:05.152825587 -0500
|
||||||
@@ -482,7 +482,6 @@ tests/Makefile
|
+++ gst-plugins-ugly-1.12.4/configure.ac 2018-02-11 20:18:33.859767165 -0500
|
||||||
|
@@ -474,7 +474,6 @@
|
||||||
tests/check/Makefile
|
tests/check/Makefile
|
||||||
tests/files/Makefile
|
tests/files/Makefile
|
||||||
m4/Makefile
|
m4/Makefile
|
||||||
-po/Makefile.in
|
-po/Makefile.in
|
||||||
pkgconfig/Makefile
|
pkgconfig/Makefile
|
||||||
pkgconfig/gstreamer-plugins-ugly-uninstalled.pc
|
pkgconfig/gstreamer-plugins-ugly-uninstalled.pc
|
||||||
gst-plugins-ugly.spec
|
)
|
||||||
--- a/Makefile.am
|
diff -u --recursive gst-plugins-ugly-1.12.4-vanilla/Makefile.am gst-plugins-ugly-1.12.4/Makefile.am
|
||||||
+++ b/Makefile.am
|
--- gst-plugins-ugly-1.12.4-vanilla/Makefile.am 2018-02-11 20:18:05.157825577 -0500
|
||||||
|
+++ gst-plugins-ugly-1.12.4/Makefile.am 2018-02-11 20:18:23.491788265 -0500
|
||||||
@@ -1,7 +1,7 @@
|
@@ -1,7 +1,7 @@
|
||||||
DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
|
DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
|
||||||
|
|
||||||
|
@ -17,5 +19,5 @@
|
||||||
- gst-libs gst ext docs m4 tests common pkgconfig po
|
- gst-libs gst ext docs m4 tests common pkgconfig po
|
||||||
+ gst-libs gst ext docs m4 tests common pkgconfig
|
+ gst-libs gst ext docs m4 tests common pkgconfig
|
||||||
|
|
||||||
# include before EXTRA_DIST for win32 assignment
|
EXTRA_DIST = \
|
||||||
include $(top_srcdir)/common/win32.mak
|
depcomp \
|
||||||
|
|
|
@ -1,6 +1,7 @@
|
||||||
--- a/configure.ac
|
diff -u --recursive gst-plugins-ugly-1.12.4-vanilla/configure.ac gst-plugins-ugly-1.12.4/configure.ac
|
||||||
+++ b/configure.ac
|
--- gst-plugins-ugly-1.12.4-vanilla/configure.ac 2018-02-11 20:19:01.875710150 -0500
|
||||||
@@ -478,9 +478,6 @@ ext/x264/Makefile
|
+++ gst-plugins-ugly-1.12.4/configure.ac 2018-02-11 20:19:27.117658780 -0500
|
||||||
|
@@ -470,9 +470,6 @@
|
||||||
docs/Makefile
|
docs/Makefile
|
||||||
docs/plugins/Makefile
|
docs/plugins/Makefile
|
||||||
docs/version.entities
|
docs/version.entities
|
||||||
|
@ -10,8 +11,9 @@
|
||||||
m4/Makefile
|
m4/Makefile
|
||||||
pkgconfig/Makefile
|
pkgconfig/Makefile
|
||||||
pkgconfig/gstreamer-plugins-ugly-uninstalled.pc
|
pkgconfig/gstreamer-plugins-ugly-uninstalled.pc
|
||||||
--- a/Makefile.am
|
diff -u --recursive gst-plugins-ugly-1.12.4-vanilla/Makefile.am gst-plugins-ugly-1.12.4/Makefile.am
|
||||||
+++ b/Makefile.am
|
--- gst-plugins-ugly-1.12.4-vanilla/Makefile.am 2018-02-11 20:19:01.875710150 -0500
|
||||||
|
+++ gst-plugins-ugly-1.12.4/Makefile.am 2018-02-11 20:19:34.402643954 -0500
|
||||||
@@ -1,7 +1,7 @@
|
@@ -1,7 +1,7 @@
|
||||||
DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
|
DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
|
||||||
|
|
||||||
|
@ -19,5 +21,5 @@
|
||||||
- gst-libs gst ext docs m4 tests common pkgconfig
|
- gst-libs gst ext docs m4 tests common pkgconfig
|
||||||
+ gst-libs gst ext docs m4 common pkgconfig
|
+ gst-libs gst ext docs m4 common pkgconfig
|
||||||
|
|
||||||
# include before EXTRA_DIST for win32 assignment
|
EXTRA_DIST = \
|
||||||
include $(top_srcdir)/common/win32.mak
|
depcomp \
|
||||||
|
|
|
@ -1,6 +1,7 @@
|
||||||
--- a/configure.ac
|
diff -u --recursive gst-plugins-ugly-1.12.4-vanilla/configure.ac gst-plugins-ugly-1.12.4/configure.ac
|
||||||
+++ b/configure.ac
|
--- gst-plugins-ugly-1.12.4-vanilla/configure.ac 2018-02-11 20:19:47.318617668 -0500
|
||||||
@@ -475,9 +475,6 @@ ext/mpg123/Makefile
|
+++ gst-plugins-ugly-1.12.4/configure.ac 2018-02-11 20:19:56.171599652 -0500
|
||||||
|
@@ -467,9 +467,6 @@
|
||||||
ext/sidplay/Makefile
|
ext/sidplay/Makefile
|
||||||
ext/twolame/Makefile
|
ext/twolame/Makefile
|
||||||
ext/x264/Makefile
|
ext/x264/Makefile
|
||||||
|
@ -10,8 +11,9 @@
|
||||||
m4/Makefile
|
m4/Makefile
|
||||||
pkgconfig/Makefile
|
pkgconfig/Makefile
|
||||||
pkgconfig/gstreamer-plugins-ugly-uninstalled.pc
|
pkgconfig/gstreamer-plugins-ugly-uninstalled.pc
|
||||||
--- a/Makefile.am
|
diff -u --recursive gst-plugins-ugly-1.12.4-vanilla/Makefile.am gst-plugins-ugly-1.12.4/Makefile.am
|
||||||
+++ b/Makefile.am
|
--- gst-plugins-ugly-1.12.4-vanilla/Makefile.am 2018-02-11 20:19:47.318617668 -0500
|
||||||
|
+++ gst-plugins-ugly-1.12.4/Makefile.am 2018-02-11 20:20:03.662584407 -0500
|
||||||
@@ -1,7 +1,7 @@
|
@@ -1,7 +1,7 @@
|
||||||
DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
|
DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
|
||||||
|
|
||||||
|
@ -19,5 +21,5 @@
|
||||||
- gst-libs gst ext docs m4 common pkgconfig
|
- gst-libs gst ext docs m4 common pkgconfig
|
||||||
+ gst-libs gst ext m4 common pkgconfig
|
+ gst-libs gst ext m4 common pkgconfig
|
||||||
|
|
||||||
# include before EXTRA_DIST for win32 assignment
|
EXTRA_DIST = \
|
||||||
include $(top_srcdir)/common/win32.mak
|
depcomp \
|
||||||
|
|
Loading…
Reference in a new issue