libreswan: update to 4.5
Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
This commit is contained in:
parent
05d9d7ae21
commit
b2efa063d2
3 changed files with 4 additions and 14 deletions
|
@ -7,12 +7,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=libreswan
|
PKG_NAME:=libreswan
|
||||||
PKG_VERSION:=4.4
|
PKG_VERSION:=4.5
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://download.libreswan.org/
|
PKG_SOURCE_URL:=https://download.libreswan.org/
|
||||||
PKG_HASH:=5f3f0a20d7097f20108bc93ba1255a778d8ffb8692d05f86383978c03c394976
|
PKG_HASH:=0703f51bdc6674d4ba66adb50854df9e0731bfa78a8983ebc2aa3adc55dd90a3
|
||||||
|
|
||||||
PKG_MAINTAINER:=Lucian Cristian <lucian.cristian@gmail.com>
|
PKG_MAINTAINER:=Lucian Cristian <lucian.cristian@gmail.com>
|
||||||
PKG_LICENSE:=GPL-2.0-or-later
|
PKG_LICENSE:=GPL-2.0-or-later
|
||||||
|
@ -76,7 +76,7 @@ MAKE_FLAGS+= \
|
||||||
USE_NSS_KDF=true \
|
USE_NSS_KDF=true \
|
||||||
USE_LIBCURL=false \
|
USE_LIBCURL=false \
|
||||||
USE_GLIBC_KERN_FLIP_HEADERS=true \
|
USE_GLIBC_KERN_FLIP_HEADERS=true \
|
||||||
USE_XAUTHPAM=false \
|
USE_AUTHPAM=false \
|
||||||
USE_LIBCAP_NG=true \
|
USE_LIBCAP_NG=true \
|
||||||
USE_SYSTEMD_WATCHDOG=false \
|
USE_SYSTEMD_WATCHDOG=false \
|
||||||
USE_SECCOMP=false\
|
USE_SECCOMP=false\
|
||||||
|
|
|
@ -9,7 +9,7 @@
|
||||||
#include <errno.h>
|
#include <errno.h>
|
||||||
|
|
||||||
#include "defs.h"
|
#include "defs.h"
|
||||||
@@ -192,7 +192,8 @@ static bool send_chunks(const char *wher
|
@@ -192,7 +192,8 @@ static bool send_shunks(const char *wher
|
||||||
*/
|
*/
|
||||||
if (impair.jacob_two_two) {
|
if (impair.jacob_two_two) {
|
||||||
/* sleep for half a second, and second another packet */
|
/* sleep for half a second, and second another packet */
|
||||||
|
|
|
@ -1,10 +0,0 @@
|
||||||
--- a/include/fd.h
|
|
||||||
+++ b/include/fd.h
|
|
||||||
@@ -26,6 +26,7 @@
|
|
||||||
|
|
||||||
#include <stdbool.h>
|
|
||||||
#include <stdlib.h> /* for ssize_t */
|
|
||||||
+#include <sys/types.h>
|
|
||||||
|
|
||||||
#include "where.h"
|
|
||||||
|
|
Loading…
Reference in a new issue