libgpg-error: update to 1.32
Signed-off-by: W. Michael Petullo <mike@flyn.org>
This commit is contained in:
parent
3fdef4e2f3
commit
b2ba4a2e08
3 changed files with 27 additions and 57 deletions
|
@ -8,18 +8,20 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libgpg-error
|
||||
PKG_VERSION:=1.12
|
||||
PKG_VERSION:=1.32
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=ftp://ftp.gnupg.org/gcrypt/libgpg-error
|
||||
PKG_HASH:=cafc9ed6a87c53a35175d5a1220a96ca386696eef2fa059cc0306211f246e55f
|
||||
PKG_SOURCE_URL:=https://www.gnupg.org/ftp/gcrypt/libgpg-error/
|
||||
PKG_HASH:=c345c5e73cc2332f8d50db84a2280abfb1d8f6d4f1858b9daa30404db44540ca
|
||||
PKG_LICENSE:=LGPL-2.1+
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_INSTALL:=1
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/libgpg-error
|
||||
|
|
22
libs/libgpg-error/patches/001-cross-compile-fix.patch
Normal file
22
libs/libgpg-error/patches/001-cross-compile-fix.patch
Normal file
|
@ -0,0 +1,22 @@
|
|||
diff -u --recursive libgpg-error-1.32-vanilla/configure.ac libgpg-error-1.32/configure.ac
|
||||
--- libgpg-error-1.32-vanilla/configure.ac 2018-07-15 01:23:30.028462129 -0400
|
||||
+++ libgpg-error-1.32/configure.ac 2018-07-15 01:25:32.214267179 -0400
|
||||
@@ -74,6 +74,18 @@
|
||||
AC_CANONICAL_HOST
|
||||
AB_INIT
|
||||
|
||||
+case "${host}" in
|
||||
+ x86_64-openwrt-linux-gnu|i?86-openwrt-linux-gnu)
|
||||
+ host=$(echo $host | sed 's/openwrt/pc/g')
|
||||
+ ;;
|
||||
+ arm-openwrt-linux-gnu)
|
||||
+ host=arm-unknown-linux-gnueabi
|
||||
+ ;;
|
||||
+ *)
|
||||
+ host=$(echo $host | sed 's/openwrt/unknown/g')
|
||||
+ ;;
|
||||
+esac
|
||||
+
|
||||
# Checks for programs.
|
||||
AC_PROG_CC
|
||||
AM_PROG_CC_C_O
|
|
@ -1,54 +0,0 @@
|
|||
From: Daniel Kahn Gillmor <dkg@fifthhorseman.net>
|
||||
Date: Mon, 16 Mar 2015 17:40:12 +0000 (-0400)
|
||||
Subject: Avoid breakage with gcc 5
|
||||
X-Git-Tag: libgpg-error-1.19~7
|
||||
X-Git-Url: http://git.gnupg.org/cgi-bin/gitweb.cgi?p=libgpg-error.git;a=commitdiff_plain;h=c01c8f0c4f55d76b037c7f6aa44ad25ede18d38a
|
||||
|
||||
Avoid breakage with gcc 5
|
||||
|
||||
* src/Makefile.am: Add -P to the C preprocessor when building
|
||||
mkerrcodes.h, to avoid a noisy intermediate pipeline.
|
||||
|
||||
--
|
||||
|
||||
With gcc 5 without this patch, we see many errors like the following:
|
||||
|
||||
gcc -I. -I. -o mkerrcodes ./mkerrcodes.c
|
||||
In file included from ./mkerrcodes.c:26:0:
|
||||
./mkerrcodes.h:9:5: error: expected expression before ‘,’ token
|
||||
{ , "GPG_ERR_E2BIG" },
|
||||
^
|
||||
./mkerrcodes.h:10:5: error: expected expression before ‘,’ token
|
||||
{ , "GPG_ERR_EACCES" },
|
||||
^
|
||||
|
||||
This patch cleans up the generated mkerrcodes.h by making the
|
||||
intermediate stage clean for all the versions of gcc i tested (4.x and
|
||||
5).
|
||||
|
||||
Debian-Bug-Id: 777374
|
||||
Signed-Off-By: Daniel Kahn Gillmor <dkg@fifthhorseman.net>
|
||||
---
|
||||
|
||||
--- a/src/Makefile.am
|
||||
+++ b/src/Makefile.am
|
||||
@@ -140,7 +140,7 @@ code-to-errno.h: Makefile mkerrnos.awk e
|
||||
# It is correct to use $(CPP). We want the host's idea of the error codes.
|
||||
mkerrcodes.h: Makefile mkerrcodes.awk $(gpg_extra_headers)
|
||||
$(AWK) -f $(srcdir)/mkerrcodes1.awk $(srcdir)/errnos.in >_$@
|
||||
- $(CPP) $(CPPFLAGS) $(extra_cppflags) _$@ | grep GPG_ERR_ | \
|
||||
+ $(CPP) $(CPPFLAGS) $(extra_cppflags) -P _$@ | grep GPG_ERR_ | \
|
||||
$(AWK) -f $(srcdir)/mkerrcodes.awk >$@
|
||||
-rm _$@
|
||||
|
||||
--- a/src/Makefile.in
|
||||
+++ b/src/Makefile.in
|
||||
@@ -979,7 +979,7 @@ code-to-errno.h: Makefile mkerrnos.awk e
|
||||
# It is correct to use $(CPP). We want the host's idea of the error codes.
|
||||
mkerrcodes.h: Makefile mkerrcodes.awk $(gpg_extra_headers)
|
||||
$(AWK) -f $(srcdir)/mkerrcodes1.awk $(srcdir)/errnos.in >_$@
|
||||
- $(CPP) $(CPPFLAGS) $(extra_cppflags) _$@ | grep GPG_ERR_ | \
|
||||
+ $(CPP) $(CPPFLAGS) $(extra_cppflags) -P _$@ | grep GPG_ERR_ | \
|
||||
$(AWK) -f $(srcdir)/mkerrcodes.awk >$@
|
||||
-rm _$@
|
||||
|
Loading…
Reference in a new issue