luasocket: update to 3.0.0
Signed-off-by: W. Michael Petullo <mike@flyn.org>
This commit is contained in:
parent
953d33f661
commit
b1d67bd944
3 changed files with 6 additions and 21 deletions
|
@ -8,13 +8,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=luasocket
|
PKG_NAME:=luasocket
|
||||||
PKG_SOURCE_DATE:=2019-04-21
|
PKG_VERSION:=3.0.0
|
||||||
PKG_SOURCE_VERSION:=733af884f1aa18ff469bf3c4d18810e815853211
|
PKG_RELEASE:=$(AUTORELEASE)
|
||||||
PKG_RELEASE:=1
|
|
||||||
|
|
||||||
PKG_SOURCE_PROTO:=git
|
PKG_SOURCE:=v$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://github.com/diegonehab/luasocket
|
PKG_SOURCE_URL:=https://github.com/lunarmodules/luasocket/archive/refs/tags
|
||||||
PKG_MIRROR_HASH:=60aef7544426cae3e6c7560a6e4ad556a04b879ca0ad0311645b2c513c872128
|
PKG_HASH:=04d98e40edcee7c7c5f83f0e8ba5503d14b56280e20daceee9e34ed7cf8f1b15
|
||||||
|
|
||||||
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
|
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
|
||||||
PKG_LICENSE:=MIT
|
PKG_LICENSE:=MIT
|
||||||
|
|
|
@ -213,7 +213,7 @@ Subject: [PATCH] Add interface resolving
|
||||||
/*=========================================================================*\
|
/*=========================================================================*\
|
||||||
* Internal functions prototypes
|
* Internal functions prototypes
|
||||||
\*=========================================================================*/
|
\*=========================================================================*/
|
||||||
@@ -388,6 +391,12 @@ static int opt_ip6_setmembership(lua_Sta
|
@@ -389,6 +392,12 @@ static int opt_ip6_setmembership(lua_Sta
|
||||||
if (!lua_isnil(L, -1)) {
|
if (!lua_isnil(L, -1)) {
|
||||||
if (lua_isnumber(L, -1)) {
|
if (lua_isnumber(L, -1)) {
|
||||||
val.ipv6mr_interface = (unsigned int) lua_tonumber(L, -1);
|
val.ipv6mr_interface = (unsigned int) lua_tonumber(L, -1);
|
||||||
|
|
|
@ -1,14 +0,0 @@
|
||||||
--- a/src/makefile
|
|
||||||
+++ b/src/makefile
|
|
||||||
@@ -174,9 +174,8 @@ SO_linux=so
|
|
||||||
O_linux=o
|
|
||||||
CC_linux=gcc
|
|
||||||
DEF_linux=-DLUASOCKET_$(DEBUG)
|
|
||||||
-CFLAGS_linux=$(LUAINC:%=-I%) $(DEF) -Wall -Wshadow -Wextra \
|
|
||||||
- -Wimplicit -O2 -ggdb3 -fpic
|
|
||||||
-LDFLAGS_linux=-O -shared -fpic -o
|
|
||||||
+CFLAGS_linux=$(LUAINC:%=-I%) $(DEF) -O2
|
|
||||||
+LDFLAGS_linux=-O -shared -o
|
|
||||||
LD_linux=gcc
|
|
||||||
SOCKET_linux=usocket.o
|
|
||||||
|
|
Loading…
Reference in a new issue