loudmouth: Disable debug and fix no deprecated API compilation
Signed-off-by: Rosen Penev <rosenp@gmail.com>
(cherry-picked from 788fda356e
)
This commit is contained in:
parent
30ddc8a151
commit
b1adbbe5b1
2 changed files with 19 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=loudmouth
|
||||
PKG_VERSION:=1.5.3
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
|
||||
|
||||
|
@ -46,6 +46,10 @@ CONFIGURE_ARGS += \
|
|||
--without-idn \
|
||||
--with-ssl=openssl
|
||||
|
||||
CONFIGURE_VARS += \
|
||||
ac_cv_lib_crypto_BIO_f_base64=yes \
|
||||
ac_cv_lib_ssl_SSL_new=yes
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/include/
|
||||
$(CP) \
|
||||
|
|
14
libs/loudmouth/patches/020-openssl-deprecated.patch
Normal file
14
libs/loudmouth/patches/020-openssl-deprecated.patch
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- a/loudmouth/lm-ssl-openssl.c
|
||||
+++ b/loudmouth/lm-ssl-openssl.c
|
||||
@@ -345,9 +345,11 @@ _lm_ssl_initialize (LmSSL *ssl)
|
||||
/*const char *cert_file = NULL;*/
|
||||
|
||||
if (!initialized) {
|
||||
+#if OPENSSL_VERSION_NUMBER < 0x10100000L
|
||||
SSL_library_init();
|
||||
/* FIXME: Is this needed when we are not in debug? */
|
||||
SSL_load_error_strings();
|
||||
+#endif
|
||||
initialized = TRUE;
|
||||
}
|
||||
|
Loading…
Reference in a new issue