mpd: update to 0.23.9
Fixes compilation with newer ffmpeg. Remove upstreamed patch. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
8bf399f78e
commit
b1999ec133
2 changed files with 2 additions and 41 deletions
|
@ -6,12 +6,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=mpd
|
PKG_NAME:=mpd
|
||||||
PKG_VERSION:=0.23.8
|
PKG_VERSION:=0.23.9
|
||||||
PKG_RELEASE:=$(AUTORELEASE)
|
PKG_RELEASE:=$(AUTORELEASE)
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=https://www.musicpd.org/download/mpd/0.23
|
PKG_SOURCE_URL:=https://www.musicpd.org/download/mpd/0.23
|
||||||
PKG_HASH:=86bb569bf3b519821f36f6bb5564e484e85d2564411b34b200fe2cd3a04e78cf
|
PKG_HASH:=2becaba980402e8dc7972ccc3476e493b7ae2eeb720d31fa6712472ed48e9f2d
|
||||||
|
|
||||||
PKG_MAINTAINER:=
|
PKG_MAINTAINER:=
|
||||||
PKG_LICENSE:=GPL-2.0-or-later
|
PKG_LICENSE:=GPL-2.0-or-later
|
||||||
|
|
|
@ -1,39 +0,0 @@
|
||||||
From 8ece1141e455d6643df0be885a5df200bdb3bc78 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Rosen Penev <rosenp@gmail.com>
|
|
||||||
Date: Thu, 30 Jul 2020 14:34:07 -0700
|
|
||||||
Subject: [PATCH] icu/meson: link against iconv when used externally
|
|
||||||
|
|
||||||
This basically adds -liconv to LDFLAGS, fixing a linking issue when
|
|
||||||
iconv is missing in the libc.
|
|
||||||
|
|
||||||
The previous commit fixed finding iconv but did not fix linking.
|
|
||||||
|
|
||||||
Switched to using c_compiler for iconv. It seems compiler does not work
|
|
||||||
properly.
|
|
||||||
|
|
||||||
Signed-off-by: Rosen Penev <rosenp@gmail.com>
|
|
||||||
---
|
|
||||||
src/lib/icu/meson.build | 14 ++++++++++++--
|
|
||||||
1 file changed, 12 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
--- a/src/lib/icu/meson.build
|
|
||||||
+++ b/src/lib/icu/meson.build
|
|
||||||
@@ -19,16 +19,8 @@ if icu_dep.found()
|
|
||||||
'Init.cxx',
|
|
||||||
]
|
|
||||||
elif not get_option('iconv').disabled()
|
|
||||||
- # an installed iconv library will make the builtin iconv() unavailable,
|
|
||||||
- # so search for the library first and pass it as (possible) dependency
|
|
||||||
- iconv_dep = compiler.find_library('libiconv', required: false)
|
|
||||||
- have_iconv = compiler.has_function('iconv',
|
|
||||||
- dependencies: iconv_dep,
|
|
||||||
- prefix : '#include <iconv.h>')
|
|
||||||
- if not have_iconv and get_option('iconv').enabled()
|
|
||||||
- error('iconv() not available')
|
|
||||||
- endif
|
|
||||||
- conf.set('HAVE_ICONV', have_iconv)
|
|
||||||
+ iconv_dep = dependency('iconv')
|
|
||||||
+ conf.set('HAVE_ICONV', iconv_dep.found())
|
|
||||||
endif
|
|
||||||
|
|
||||||
icu = static_library(
|
|
Loading…
Reference in a new issue