diff --git a/net/dnsdist/Makefile b/net/dnsdist/Makefile
index 62ca755a0..b0d8f3c50 100644
--- a/net/dnsdist/Makefile
+++ b/net/dnsdist/Makefile
@@ -1,12 +1,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsdist
-PKG_VERSION:=1.5.1
-PKG_RELEASE:=1
+PKG_VERSION:=1.6.0
+PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://downloads.powerdns.com/releases/
-PKG_HASH:=cae759729a87703f4d09b0ed4227cb224aaaa252fa92f2432fd7116f560afbf1
+PKG_HASH:=a7783a04d8d4ad2b0168ffaaf85ef95d5f557057b0462280684dd799d0cdd292
 
 PKG_MAINTAINER:=James Taylor <james@jtaylor.id.au>
 PKG_LICENSE:=GPL-2.0-only
@@ -17,7 +17,7 @@ PKG_INSTALL:=1
 PKG_BUILD_PARALLEL:=1
 
 PKG_ASLR_PIE:=0
-PKG_BUILD_DEPENDS:=protobuf/host
+PKG_BUILD_DEPENDS:=boost
 
 PKG_CONFIG_DEPENDS:= \
   CONFIG_DNSDIST_GNUTLS \
@@ -74,7 +74,6 @@ define Package/dnsdist
 	  +DNSDIST_DNS_OVER_HTTPS:libh2o-evloop \
 	  +DNSDIST_GNUTLS:libgnutls \
 	  +DNSDIST_OPENSSL:libopenssl \
-	  +boost \
 	  +libatomic \
 	  +libcap \
 	  +libedit \
@@ -82,9 +81,8 @@ define Package/dnsdist
 	  +libnetsnmp \
 	  +libsodium \
 	  +lmdb \
-	  +lua \
-	  +protobuf \
 	  +re2 \
+	  +liblua \
 	  +tinycdb
   URL:=https://dnsdist.org/
 endef
@@ -101,12 +99,15 @@ define Package/dnsdist/conffiles
 /etc/init.d/dnsdist
 endef
 
+# not everything groks --disable-nls
+DISABLE_NLS:=
+
 CONFIGURE_ARGS+= \
+	--enable-option-checking=fatal \
 	--enable-dnscrypt \
 	--enable-dnstap \
 	--with-libsodium \
 	--with-pic \
-	--with-protobuf \
 	--with-re2 \
 	--with-lua=lua \
 	--with-net-snmp \
diff --git a/net/dnsdist/patches/010-time_t-check.patch b/net/dnsdist/patches/010-time_t-check.patch
new file mode 100644
index 000000000..e8760e4b5
--- /dev/null
+++ b/net/dnsdist/patches/010-time_t-check.patch
@@ -0,0 +1,12 @@
+--- a/configure
++++ b/configure
+@@ -5044,9 +5044,6 @@ cat >>confdefs.h <<_ACEOF
+ _ACEOF
+ 
+ 
+-if test $ac_size -lt 8; then :
+-  as_fn_error $? "size of time_t is $ac_size, which is not large enough to fix the y2k38 bug" "$LINENO" 5
+-fi
+ 
+  typename=`echo time_t | sed "s/[^a-zA-Z0-9_]/_/g"`
+  { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether time_t is signed" >&5