libpng: import from oldpackages, add myself as maintainer, change PKG_LICENSE to SPDX identifiers, update to v1.2.51
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
This commit is contained in:
parent
6a87c8d6a2
commit
b172d28c37
2 changed files with 78 additions and 0 deletions
68
libs/libpng/Makefile
Normal file
68
libs/libpng/Makefile
Normal file
|
@ -0,0 +1,68 @@
|
|||
#
|
||||
# Copyright (C) 2006-2014 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libpng
|
||||
PKG_VERSION:=1.2.51
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@SF/libpng
|
||||
PKG_MD5SUM:=4efba67fa5aa2b785c6fcec2cc3e90c9
|
||||
PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
|
||||
|
||||
PKG_LICENSE:=Libpng GPL-2.0+ BSD-3-Clause
|
||||
PKC_LICENSE_FILES:=LICENSE contrib/gregbook/COPYING contrib/gregbook/LICENSE
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/host-build.mk
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/libpng
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
DEPENDS:=+zlib
|
||||
TITLE:=A PNG format files handling library
|
||||
URL:=http://www.libpng.org/pub/png/libpng.html
|
||||
endef
|
||||
|
||||
TARGET_CFLAGS += $(FPIC)
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--enable-shared \
|
||||
--enable-static \
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/libpng{,12}-config $(1)/usr/bin/
|
||||
$(SED) \
|
||||
's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
|
||||
$(1)/usr/bin/libpng{,12}-config
|
||||
$(INSTALL_DIR) $(1)/usr/include
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/png{,conf}.h $(1)/usr/include/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/libpng12 $(1)/usr/include/
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libpng{,12}.{a,la,so*} $(1)/usr/lib/
|
||||
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libpng{,12}.pc $(1)/usr/lib/pkgconfig/
|
||||
$(INSTALL_DIR) $(2)/bin
|
||||
for f in libpng{,12}-config; do \
|
||||
$(LN) ../../usr/bin/$$$$f $(2)/bin/ ; \
|
||||
done
|
||||
endef
|
||||
|
||||
define Package/libpng/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libpng{,12}.so.* $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
$(eval $(call HostBuild))
|
||||
$(eval $(call BuildPackage,libpng))
|
10
libs/libpng/patches/100-config_fix.patch
Normal file
10
libs/libpng/patches/100-config_fix.patch
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- a/scripts/libpng-config-body.in
|
||||
+++ b/scripts/libpng-config-body.in
|
||||
@@ -83,6 +83,7 @@ while test $# -gt 0; do
|
||||
|
||||
--static)
|
||||
R_opts=""
|
||||
+ libs=${all_libs}
|
||||
;;
|
||||
|
||||
*)
|
Loading…
Reference in a new issue