nano: update to 3.1
* Update nano editor to 3.1 * Apply a post-release upstream patch to fix compilation Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
This commit is contained in:
parent
8bbc9c7dbe
commit
af86b17064
2 changed files with 31 additions and 2 deletions
|
@ -8,14 +8,14 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=nano
|
PKG_NAME:=nano
|
||||||
PKG_VERSION:=3.0
|
PKG_VERSION:=3.1
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
PKG_LICENSE:=GPL-3.0+
|
PKG_LICENSE:=GPL-3.0+
|
||||||
PKG_LICENSE_FILES:=COPYING
|
PKG_LICENSE_FILES:=COPYING
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=@GNU/nano
|
PKG_SOURCE_URL:=@GNU/nano
|
||||||
PKG_HASH:=e0a5bca354514e64762c987c200a8758b05e7bcced3b00b3e48ea0a2d383c8a0
|
PKG_HASH:=14c02ca40a5bc61c580ce2f9cb7f9fc72d5ccc9da17ad044f78f6fb3fdb7719e
|
||||||
|
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
PKG_BUILD_PARALLEL:=1
|
PKG_BUILD_PARALLEL:=1
|
||||||
|
|
|
@ -0,0 +1,29 @@
|
||||||
|
From 368ec04870a366b19f1c5801a6868786547968b0 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Benno Schulenberg <bensberg@telfort.nl>
|
||||||
|
Date: Wed, 19 Sep 2018 20:36:39 +0200
|
||||||
|
Subject: build: fix compilation again when configured with --enable-tiny
|
||||||
|
|
||||||
|
Reported-by: Jordi Mallach <jordi@mallach.net>
|
||||||
|
---
|
||||||
|
src/nano.c | 5 ++++-
|
||||||
|
1 file changed, 4 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/src/nano.c b/src/nano.c
|
||||||
|
index ebb1f11..01f92a1 100644
|
||||||
|
--- a/src/nano.c
|
||||||
|
+++ b/src/nano.c
|
||||||
|
@@ -1756,7 +1756,10 @@ int do_input(bool allow_funcs)
|
||||||
|
if (shortcut == NULL)
|
||||||
|
pletion_line = NULL;
|
||||||
|
else {
|
||||||
|
- if (ISSET(VIEW_MODE) && shortcut->func != do_toggle_void &&
|
||||||
|
+ if (ISSET(VIEW_MODE) &&
|
||||||
|
+#ifndef NANO_TINY
|
||||||
|
+ shortcut->func != do_toggle_void &&
|
||||||
|
+#endif
|
||||||
|
!okay_for_view(shortcut)) {
|
||||||
|
print_view_warning();
|
||||||
|
return ERR;
|
||||||
|
--
|
||||||
|
cgit v1.0-41-gc330
|
||||||
|
|
Loading…
Reference in a new issue