strongswan: Update to 5.9.9

Add patch to remove definition of RNG leaking in from wolfssl.h.

Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
This commit is contained in:
Philip Prindeville 2023-01-10 22:28:53 -07:00
parent bf51e33b57
commit ae0a8072d6
2 changed files with 15 additions and 3 deletions

View file

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=strongswan
PKG_VERSION:=5.9.8
PKG_RELEASE:=5
PKG_VERSION:=5.9.9
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://download.strongswan.org/ https://download2.strongswan.org/
PKG_HASH:=d3303a43c0bd7b75a12b64855e8edcb53696f06190364f26d1533bde1f2e453c
PKG_HASH:=5e16580998834658c17cebfb31dd637e728669cf2fdd325460234a4643b8d81d
PKG_LICENSE:=GPL-2.0-or-later
PKG_MAINTAINER:=Philip Prindeville <philipp@redfish-solutions.com>, Noel Kuntze <noel.kuntze@thermi.consulting>
PKG_CPE_ID:=cpe:/a:strongswan:strongswan

View file

@ -0,0 +1,12 @@
--- a/src/libstrongswan/plugins/wolfssl/wolfssl_plugin.c
+++ b/src/libstrongswan/plugins/wolfssl/wolfssl_plugin.c
@@ -50,6 +50,9 @@
#ifndef FIPS_MODE
#define FIPS_MODE 0
#endif
+#ifdef RNG
+#undef RNG
+#endif
typedef struct private_wolfssl_plugin_t private_wolfssl_plugin_t;