zabbix: update to 2.4.0, refresh patches
Signed-off-by: Christoph König <christoph.koenig@gmail.com> Signed-off-by: Etienne CHAMPETIER <champetier.etienne@gmail.com>
This commit is contained in:
parent
e1dc92d52e
commit
ada4d17911
4 changed files with 13 additions and 12 deletions
|
@ -1,5 +1,5 @@
|
|||
#
|
||||
# Copyright (C) 2006-2013 OpenWrt.org
|
||||
# Copyright (C) 2006-2014 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=zabbix
|
||||
PKG_VERSION:=2.2.6
|
||||
PKG_VERSION:=2.4.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/zabbix
|
||||
PKG_MD5SUM:=38bc2407f80053d71853bb3419da364a
|
||||
PKG_MD5SUM:=57d9bf72bf0732971e4540a402bfc6c6
|
||||
|
||||
PKG_LICENSE:=GPLv2
|
||||
PKG_LICENSE_FILES:=
|
||||
|
|
|
@ -13,15 +13,15 @@
|
|||
dnl * *
|
||||
--- a/src/libs/zbxsysinfo/common/net.c
|
||||
+++ b/src/libs/zbxsysinfo/common/net.c
|
||||
@@ -425,6 +425,7 @@ static int dns_query(AGENT_REQUEST *requ
|
||||
if (-1 == res_init()) /* initialize always, settings might have changed */
|
||||
@@ -450,6 +450,7 @@ static int dns_query(AGENT_REQUEST *requ
|
||||
return SYSINFO_RET_FAIL;
|
||||
}
|
||||
|
||||
+#if defined(HAVE_RES_MKQUERY) && defined(HAVE_RES_SEND)
|
||||
if (-1 == (res = res_mkquery(QUERY, zone, C_IN, type, NULL, 0, NULL, buf, sizeof(buf))))
|
||||
return SYSINFO_RET_FAIL;
|
||||
|
||||
@@ -449,6 +450,11 @@ static int dns_query(AGENT_REQUEST *requ
|
||||
{
|
||||
SET_MSG_RESULT(result, zbx_dsprintf(NULL, "Cannot create DNS query: %s", zbx_strerror(errno)));
|
||||
@@ -480,6 +481,11 @@ static int dns_query(AGENT_REQUEST *requ
|
||||
_res.retry = retry;
|
||||
|
||||
res = res_send(buf, res, answer.buffer, sizeof(answer.buffer));
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
--- a/src/libs/zbxsysinfo/linux/cpu.c
|
||||
+++ b/src/libs/zbxsysinfo/linux/cpu.c
|
||||
@@ -21,6 +21,45 @@
|
||||
#include "sysinfo.h"
|
||||
#include "stats.h"
|
||||
@@ -62,6 +62,45 @@ int SYSTEM_CPU_DISCOVERY(AGENT_REQUEST *
|
||||
return SYSINFO_RET_OK;
|
||||
}
|
||||
|
||||
+
|
||||
+/* uclibc and dietlibc do not have this junk -ReneR */
|
||||
|
|
|
@ -50,11 +50,12 @@
|
|||
### Option: HostnameItem
|
||||
# Item used for generating Hostname if it is undefined. Ignored if Hostname is defined.
|
||||
# Does not support UserParameters or aliases.
|
||||
@@ -240,7 +231,7 @@ Hostname=Zabbix server
|
||||
@@ -249,8 +240,8 @@ Hostname=Zabbix server
|
||||
# Include=
|
||||
|
||||
# Include=/usr/local/etc/zabbix_agentd.userparams.conf
|
||||
-# Include=/usr/local/etc/zabbix_agentd.conf.d/
|
||||
# Include=/usr/local/etc/zabbix_agentd.conf.d/*.conf
|
||||
+Include=/etc/zabbix_agentd.conf.d/
|
||||
|
||||
####### USER-DEFINED MONITORED PARAMETERS #######
|
||||
|
|
Loading…
Reference in a new issue