mutt: bump version
* no-po-no-docs patch reworked, docs are disabled via ./configure now * drop CVE patch, fix already in upstream * autoreconf to fix CI build Signed-off-by: Phil Eichinger <phil@zankapfel.net>
This commit is contained in:
parent
4317fe0a10
commit
ad25e99fef
4 changed files with 31 additions and 61 deletions
|
@ -8,18 +8,19 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=mutt
|
||||
PKG_VERSION:=1.7.2
|
||||
PKG_VERSION:=1.9.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_URL:=ftp://ftp.mutt.org/pub/mutt/ \
|
||||
https://bitbucket.org/mutt/mutt/downloads/
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_HASH:=1553501687cd22d5b8aaee4dc5a7d9dcf6cc61d7956f6aabaadd252d10cd5ff9
|
||||
PKG_HASH:=749b83a96373c6e2101ebe8c4b9a651735e02c478edb750750a5146a15d91bb1
|
||||
|
||||
PKG_LICENSE:=GPL-2.0+
|
||||
PKG_LICENSE_FILES:=GPL
|
||||
PKG_MAINTAINER:=Phil Eichinger <phil@zankapfel.net>
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
|
||||
PKG_INSTALL:=1
|
||||
|
||||
|
@ -44,7 +45,8 @@ CONFIGURE_ARGS += \
|
|||
--enable-pop \
|
||||
--enable-imap \
|
||||
--with-ssl \
|
||||
--without-idn
|
||||
--without-idn \
|
||||
--disable-doc
|
||||
|
||||
define Package/mutt/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
|
|
|
@ -1,27 +0,0 @@
|
|||
From b0e285a8c7faaec8807fdd677da6750f341f0109 Mon Sep 17 00:00:00 2001
|
||||
From: Phil Eichinger <phil@zankapfel.net>
|
||||
Date: Thu, 19 Nov 2015 13:18:53 +0100
|
||||
Subject: [PATCH] no po and docs
|
||||
|
||||
[adapted old patch and converted to git patch]
|
||||
Signed-off-by: Phil Eichinger <phil@zankapfel.net>
|
||||
---
|
||||
Makefile.in | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile.in b/Makefile.in
|
||||
index 1909835..cfa7ca0 100644
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -470,7 +470,7 @@ get_cs_cmdline = $(call get_cs_compile,$
|
||||
AUTOMAKE_OPTIONS = 1.6 foreign
|
||||
@BUILD_IMAP_TRUE@IMAP_SUBDIR = imap
|
||||
@BUILD_IMAP_TRUE@IMAP_INCLUDES = -I$(top_srcdir)/imap
|
||||
-SUBDIRS = m4 po intl doc contrib $(IMAP_SUBDIR)
|
||||
+SUBDIRS = m4 intl contrib $(IMAP_SUBDIR)
|
||||
bin_SCRIPTS = muttbug flea $(SMIMEAUX_TARGET)
|
||||
@BUILD_HCACHE_TRUE@HCVERSION = hcversion.h
|
||||
BUILT_SOURCES = keymap_defs.h patchlist.c reldate.h conststrings.c $(HCVERSION)
|
||||
--
|
||||
2.1.4
|
||||
|
26
mail/mutt/patches/0001-no-po.patch
Normal file
26
mail/mutt/patches/0001-no-po.patch
Normal file
|
@ -0,0 +1,26 @@
|
|||
From 6dbfafd4b8bfc9f5e53db90c5279784c506a3253 Mon Sep 17 00:00:00 2001
|
||||
From: Phil Eichinger <phil@zankapfel.net>
|
||||
Date: Tue, 17 Oct 2017 06:44:04 +0200
|
||||
Subject: [PATCH] no po
|
||||
|
||||
docs are disabled via ./configure --disable-doc now
|
||||
---
|
||||
Makefile.am | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index 4bc2db4..bb00927 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -14,7 +14,7 @@ IMAP_SUBDIR = imap
|
||||
IMAP_INCLUDES = -I$(top_srcdir)/imap
|
||||
endif
|
||||
|
||||
-SUBDIRS = m4 po intl $(DOC_SUBDIR) contrib $(IMAP_SUBDIR)
|
||||
+SUBDIRS = m4 intl $(DOC_SUBDIR) contrib $(IMAP_SUBDIR)
|
||||
|
||||
bin_SCRIPTS = muttbug flea $(SMIMEAUX_TARGET)
|
||||
|
||||
--
|
||||
2.11.0
|
||||
|
|
@ -1,31 +0,0 @@
|
|||
From: Antonio Radici <antonio@debian.org>
|
||||
Date: Fri, 18 Sep 2015 11:48:47 +0200
|
||||
Subject: 771125-CVE-2014-9116-jessie
|
||||
|
||||
This patch solves the issue raised by CVE-2014-9116 in bug 771125.
|
||||
|
||||
We correctly redefine what are the whitespace characters as per RFC5322; by
|
||||
doing so we prevent mutt_substrdup from being used in a way that could lead to
|
||||
a segfault.
|
||||
|
||||
The lib.c part was written by Antonio Radici <antonio@debian.org> to prevent
|
||||
crashes due to this kind of bugs from happening again.
|
||||
|
||||
Signed-off-by: Matteo F. Vescovi <mfv@debian.org>
|
||||
---
|
||||
lib.c | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff -rupN a/lib.c b/lib.c
|
||||
--- a/lib.c
|
||||
+++ b/lib.c
|
||||
@@ -815,6 +815,9 @@ char *mutt_substrdup (const char *begin,
|
||||
size_t len;
|
||||
char *p;
|
||||
|
||||
+ if (end != NULL && end < begin)
|
||||
+ return NULL;
|
||||
+
|
||||
if (end)
|
||||
len = end - begin;
|
||||
else
|
Loading…
Reference in a new issue