faad2: update to 2.9.2
Removed upstreamed patches. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
355d2b7bef
commit
ad1203ebb9
3 changed files with 4 additions and 87 deletions
|
@ -6,13 +6,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=faad2
|
||||
PKG_VERSION:=2.9.1
|
||||
PKG_VERSION:=2.9.2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/knik0/faad2/tar.gz/2_9_1?
|
||||
PKG_HASH:=7fa33cff76abdda5a220ca5de0b2e05a77354f3b97f735193c2940224898aa9a
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-2_9_1
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/knik0/faad2/tar.gz/2_9_2?
|
||||
PKG_HASH:=9728b2b94f94ab49363cd229e7377fbe6ef3c311c5cd80da662d53ddb0ee091d
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-2_9_2
|
||||
|
||||
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
|
||||
PKG_LICENSE:=GPL-2.0-or-later
|
||||
|
|
|
@ -1,48 +0,0 @@
|
|||
From 8552fd53aaf5059ed769a0564330816beacaca98 Mon Sep 17 00:00:00 2001
|
||||
From: Rosen Penev <rosenp@gmail.com>
|
||||
Date: Tue, 10 Mar 2020 17:38:29 -0700
|
||||
Subject: [PATCH] fix compilation with LC_ONLY_DECODER
|
||||
|
||||
881b5e263f25a8a8b714e83407fc2c9dab407e40 broke compilation by always
|
||||
defining DRN and DRM_PS. Fix this and place the define where it belongs.
|
||||
---
|
||||
libfaad/Makefile.am | 2 +-
|
||||
libfaad/common.h | 7 +++++--
|
||||
2 files changed, 6 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/libfaad/Makefile.am b/libfaad/Makefile.am
|
||||
index 8ed57ae..7d9c71f 100644
|
||||
--- a/libfaad/Makefile.am
|
||||
+++ b/libfaad/Makefile.am
|
||||
@@ -32,5 +32,5 @@ libfaad_la_SOURCES = bits.c cfft.c decoder.c drc.c \
|
||||
|
||||
libfaad_drm_la_LDFLAGS = ${libfaad_la_LDFLAGS}
|
||||
libfaad_drm_la_LIBADD = ${libfaad_la_LIBADD}
|
||||
-libfaad_drm_la_CFLAGS = ${libfaad_la_CFLAGS} -DDRM -DDRM_PS
|
||||
+libfaad_drm_la_CFLAGS = ${libfaad_la_CFLAGS} -DDRM_SUPPORT
|
||||
libfaad_drm_la_SOURCES = ${libfaad_la_SOURCES}
|
||||
diff --git a/libfaad/common.h b/libfaad/common.h
|
||||
index 8b78807..76722e4 100644
|
||||
--- a/libfaad/common.h
|
||||
+++ b/libfaad/common.h
|
||||
@@ -91,8 +91,10 @@ extern "C" {
|
||||
/* Allow decoding of LD profile AAC */
|
||||
#define LD_DEC
|
||||
/* Allow decoding of Digital Radio Mondiale (DRM) */
|
||||
-//#define DRM
|
||||
-//#define DRM_PS
|
||||
+#ifdef DRM_SUPPORT
|
||||
+#define DRM
|
||||
+#define DRM_PS
|
||||
+#endif
|
||||
|
||||
/* LD can't do without LTP */
|
||||
#ifdef LD_DEC
|
||||
@@ -115,6 +117,7 @@ extern "C" {
|
||||
#undef MAIN_DEC
|
||||
#undef SSR_DEC
|
||||
#undef DRM
|
||||
+ #undef DRM_PS
|
||||
#undef ALLOW_SMALL_FRAMELENGTH
|
||||
#undef ERROR_RESILIENCE
|
||||
#endif
|
|
@ -1,35 +0,0 @@
|
|||
From 4ae9873a80ea47858d20f1d590aaf816c3aebb20 Mon Sep 17 00:00:00 2001
|
||||
From: Rosen Penev <rosenp@gmail.com>
|
||||
Date: Tue, 10 Mar 2020 20:13:57 -0700
|
||||
Subject: [PATCH] fix compilation without SBR/PS_DEC
|
||||
|
||||
The bits.h include needs to be in mp4.h as it uses the bitfield struct.
|
||||
---
|
||||
libfaad/mp4.c | 1 -
|
||||
libfaad/mp4.h | 1 +
|
||||
2 files changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/libfaad/mp4.c b/libfaad/mp4.c
|
||||
index 9f0198a..dbcff83 100644
|
||||
--- a/libfaad/mp4.c
|
||||
+++ b/libfaad/mp4.c
|
||||
@@ -33,7 +33,6 @@
|
||||
|
||||
#include <stdlib.h>
|
||||
|
||||
-#include "bits.h"
|
||||
#include "mp4.h"
|
||||
#include "syntax.h"
|
||||
|
||||
diff --git a/libfaad/mp4.h b/libfaad/mp4.h
|
||||
index 5a94be4..d99a3e3 100644
|
||||
--- a/libfaad/mp4.h
|
||||
+++ b/libfaad/mp4.h
|
||||
@@ -35,6 +35,7 @@
|
||||
extern "C" {
|
||||
#endif
|
||||
|
||||
+#include "bits.h"
|
||||
#include "neaacdec.h"
|
||||
|
||||
int8_t AudioSpecificConfig2(uint8_t *pBuffer,
|
Loading…
Reference in a new issue