ola: update to 0.10.6, fix build with recent protobuf
Recent protobuf requires C++11 while OLA was forcing C++98 in order to keep using auto_ptr without getting warnings... Use gnu++11 to make everyone happy and live with the warnings about auto_ptr being deprecated. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
This commit is contained in:
parent
b157cf4feb
commit
abdbf50221
2 changed files with 25 additions and 4 deletions
|
@ -9,15 +9,15 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=ola
|
||||
PKG_VERSION:=0.10.5
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=0.10.6
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://github.com/OpenLightingProject/ola.git
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE_VERSION:=32db3c49d435398d017c6b5c0b25e02a7a831f5c
|
||||
PKG_SOURCE_VERSION:=6e57342c414a72cdd721e8df5bc7967e17459647
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
|
||||
PKG_MIRROR_HASH:=11ed6540bd667c1662d91de93a260a9a63a98725851f768647e2b9b2efe1ae34
|
||||
PKG_MIRROR_HASH:=c1f36eaedcd9711e42fd362ff84d8e66eb40bc6af97de77129a5074d05fb9936
|
||||
PKG_LICENSE:=LGPL-2.1+
|
||||
|
||||
PKG_FIXUP:=libtool
|
||||
|
|
21
net/ola/patches/050-always-force-gnu++11.patch
Normal file
21
net/ola/patches/050-always-force-gnu++11.patch
Normal file
|
@ -0,0 +1,21 @@
|
|||
Index: ola-0.10.6/configure.ac
|
||||
===================================================================
|
||||
--- ola-0.10.6.orig/configure.ac
|
||||
+++ ola-0.10.6/configure.ac
|
||||
@@ -72,8 +72,6 @@ AM_CONDITIONAL([SUPPORTS_GNU_PLUS_PLUS_1
|
||||
require_gnu_plus_plus_11="no"
|
||||
AS_IF([test "x$ac_cv_gnu_plus_plus_11" = xyes],
|
||||
[AS_IF([test "x$ac_cv_gnu_plus_plus_98" = xyes],
|
||||
- [AS_IF([test "x$enable_unittests" = xno],
|
||||
- [CXXFLAGS="$CXXFLAGS -std=gnu++98"],
|
||||
[PKG_CHECK_MODULES([CPPUNIT1], [cppunit < 1.14.0],
|
||||
[CXXFLAGS="$CXXFLAGS -std=gnu++98"],
|
||||
[PKG_CHECK_MODULES([CPPUNIT2], [cppunit >= 1.14.0],
|
||||
@@ -81,7 +79,6 @@ AS_IF([test "x$ac_cv_gnu_plus_plus_11" =
|
||||
[AC_MSG_WARN([OLA requires std::auto_ptr support.])])
|
||||
])
|
||||
])
|
||||
- ])
|
||||
])
|
||||
AS_IF([test "x$require_gnu_plus_plus_11" = xyes],
|
||||
[CXXFLAGS="$CXXFLAGS -std=gnu++11"])
|
Loading…
Reference in a new issue