From aba3fec19872c30460f086f99c7cffe9ba3ddf72 Mon Sep 17 00:00:00 2001
From: Amol Bhave <ambhave@fb.com>
Date: Sat, 5 Jan 2019 06:42:25 -0800
Subject: [PATCH] boost: Add zstd as a dependency to boost

Depends on PR #7126

With this change:
https://github.com/boostorg/iostreams/commit/eb03aa43b9373137a51775ab63867152ff72fa00
boost iostreams supports zstd compression. If the zstd package is  built
before boost, then the packaging step complains that libzstd.so is not
packaged.

Build Tested: PR #7876 used to fail CI without this, now it passes.

Signed-off-by: Amol Bhave <ambhave@fb.com>
---
 libs/boost/Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/libs/boost/Makefile b/libs/boost/Makefile
index 35599b90b..96ee96d1c 100644
--- a/libs/boost/Makefile
+++ b/libs/boost/Makefile
@@ -342,7 +342,7 @@ $(eval $(call DefineBoostLibrary,date_time,,))
 $(eval $(call DefineBoostLibrary,fiber,coroutine filesystem,,!boost-fiber-exclude))
 $(eval $(call DefineBoostLibrary,filesystem,system,))
 $(eval $(call DefineBoostLibrary,graph,regex,))
-$(eval $(call DefineBoostLibrary,iostreams,,+zlib +liblzma +libbz2))
+$(eval $(call DefineBoostLibrary,iostreams,,+zlib +liblzma +libbz2 +zstd))
 $(eval $(call DefineBoostLibrary,locale,system,$(ICONV_DEPENDS),BUILD_NLS))
 $(eval $(call DefineBoostLibrary,log,system chrono date_time thread filesystem regex,))
 $(eval $(call DefineBoostLibrary,math,,))