owfs: update to the latest version (v3.2p2)
Changes: Makefile now downloads files from Github instead of SourceForge. Changed URL, because they decided to leave SourceForge and use Github. Added dependency libavahi-client, otherwise it doesn't build. Dropped unnecessary patches, because both were upstreamed. Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
This commit is contained in:
parent
3fdef4e2f3
commit
ab925849d2
3 changed files with 7 additions and 48 deletions
|
@ -8,12 +8,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=owfs
|
||||
PKG_VERSION:=2.9p5
|
||||
PKG_VERSION:=3.2p2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
|
||||
PKG_HASH:=f7e11bae6cd29d58726e6d29b297834e5656d6069a407d798067ae25cb0812ea
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/owfs/owfs/tar.gz/v$(PKG_VERSION)?
|
||||
PKG_HASH:=904ee3ab1d80e9d3461b310f0cc78b2175e24aa0075edc4f7f92371c667d0bb6
|
||||
|
||||
PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
|
||||
PKG_LICENSE:=GPL-2.0
|
||||
|
||||
|
@ -36,7 +37,7 @@ include $(INCLUDE_DIR)/package.mk
|
|||
|
||||
define Package/owfs/Default
|
||||
TITLE:=OWFS (1-Wire File System)
|
||||
URL:=http://owfs.sourceforge.net/
|
||||
URL:=https://github.com/owfs/owfs
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
SUBMENU:=Filesystem
|
||||
|
@ -85,7 +86,8 @@ define Package/libow
|
|||
DEPENDS:= \
|
||||
+libpthread \
|
||||
+LIBOW_MASTER_USB:libusb-compat \
|
||||
+LIBOW_MASTER_W1:kmod-w1
|
||||
+LIBOW_MASTER_W1:kmod-w1 \
|
||||
+libavahi-client
|
||||
TITLE:=OWFS - common shared library
|
||||
endef
|
||||
|
||||
|
|
|
@ -1,30 +0,0 @@
|
|||
AaAA
|
||||
--- a/module/owlib/src/c/ow_w1_parse.c
|
||||
+++ b/module/owlib/src/c/ow_w1_parse.c
|
||||
@@ -237,7 +237,7 @@ enum Netlink_Read_Status W1_Process_Resp
|
||||
owfree(nlp.nlm) ;
|
||||
return nrs_nodev ;
|
||||
}
|
||||
- if ( nrs_callback == NULL ) { // status message
|
||||
+ if ( nrs_callback == NULL ) { // bus reset
|
||||
owfree(nlp.nlm) ;
|
||||
return nrs_complete ;
|
||||
}
|
||||
@@ -246,7 +246,7 @@ enum Netlink_Read_Status W1_Process_Resp
|
||||
nrs_callback( &nlp, v, pn ) ;
|
||||
LEVEL_DEBUG("Called nrs_callback");
|
||||
owfree(nlp.nlm) ;
|
||||
- if ( nlp.cn->ack != 0 ) {
|
||||
+ if ( nlp.cn->seq != nlp.cn->ack ) {
|
||||
if ( nlp.w1m->type == W1_LIST_MASTERS ) {
|
||||
continue ; // look for more data
|
||||
}
|
||||
@@ -254,7 +254,7 @@ enum Netlink_Read_Status W1_Process_Resp
|
||||
continue ; // look for more data
|
||||
}
|
||||
}
|
||||
- nrs_callback = NULL ; // now look for status message
|
||||
+ return nrs_complete ; // status message
|
||||
}
|
||||
return nrs_timeout ;
|
||||
}
|
|
@ -1,13 +0,0 @@
|
|||
--- a/module/owlib/src/c/ow_reset.c
|
||||
+++ b/module/owlib/src/c/ow_reset.c
|
||||
@@ -21,6 +21,10 @@ RESET_TYPE BUS_reset(const struct parsed
|
||||
struct connection_in * in = pn->selected_connection ;
|
||||
STAT_ADD1_BUS(e_bus_resets, in);
|
||||
|
||||
+ if ( in->iroutines.reset == NO_RESET_ROUTINE ) {
|
||||
+ return BUS_RESET_OK;
|
||||
+ }
|
||||
+
|
||||
switch ( (in->iroutines.reset) (pn) ) {
|
||||
case BUS_RESET_OK:
|
||||
in->reconnect_state = reconnect_ok; // Flag as good!
|
Loading…
Reference in a new issue