Revert "Revert "perl-www-curl: curl 7.66.0 compatibility""
This is required as curl 7.66.0 was cherry-picked to openwrt-19.07 3
days ago. Otherwise, compilation of perl-www-curl fails.
This reverts commit ec6cd9b9c3
.
This commit is contained in:
parent
c75917c8a9
commit
aa4c5e7de6
2 changed files with 57 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=perl-www-curl
|
||||
PKG_VERSION:=4.17
|
||||
PKG_RELEASE:=5
|
||||
PKG_RELEASE:=6
|
||||
|
||||
PKG_SOURCE_URL:=http://www.cpan.org/authors/id/S/SZ/SZBALINT/
|
||||
PKG_SOURCE:=WWW-Curl-$(PKG_VERSION).tar.gz
|
||||
|
|
56
lang/perl-www-curl/patches/210-curl_7.66_compat.patch
Normal file
56
lang/perl-www-curl/patches/210-curl_7.66_compat.patch
Normal file
|
@ -0,0 +1,56 @@
|
|||
--- a/Curl.xs
|
||||
+++ b/Curl.xs
|
||||
@@ -70,7 +70,7 @@
|
||||
|
||||
|
||||
typedef struct {
|
||||
-#ifdef __CURL_MULTI_H
|
||||
+#ifdef CURLINC_MULTI_H
|
||||
struct CURLM *curlm;
|
||||
#else
|
||||
struct void *curlm;
|
||||
@@ -234,7 +234,7 @@
|
||||
{
|
||||
perl_curl_multi *self;
|
||||
Newz(1, self, 1, perl_curl_multi);
|
||||
-#ifdef __CURL_MULTI_H
|
||||
+#ifdef CURLINC_MULTI_H
|
||||
self->curlm=curl_multi_init();
|
||||
#else
|
||||
croak("curl version too old to support curl_multi_init()");
|
||||
@@ -245,7 +245,7 @@
|
||||
/* delete the multi */
|
||||
static void perl_curl_multi_delete(perl_curl_multi *self)
|
||||
{
|
||||
-#ifdef __CURL_MULTI_H
|
||||
+#ifdef CURLINC_MULTI_H
|
||||
if (self->curlm)
|
||||
curl_multi_cleanup(self->curlm);
|
||||
Safefree(self);
|
||||
@@ -1065,7 +1065,7 @@
|
||||
WWW::Curl::Multi curlm
|
||||
WWW::Curl::Easy curl
|
||||
CODE:
|
||||
-#ifdef __CURL_MULTI_H
|
||||
+#ifdef CURLINC_MULTI_H
|
||||
curl_multi_add_handle(curlm->curlm, curl->curl);
|
||||
#endif
|
||||
|
||||
@@ -1074,7 +1074,7 @@
|
||||
WWW::Curl::Multi curlm
|
||||
WWW::Curl::Easy curl
|
||||
CODE:
|
||||
-#ifdef __CURL_MULTI_H
|
||||
+#ifdef CURLINC_MULTI_H
|
||||
curl_multi_remove_handle(curlm->curlm, curl->curl);
|
||||
#endif
|
||||
|
||||
@@ -1149,7 +1149,7 @@
|
||||
PREINIT:
|
||||
int remaining;
|
||||
CODE:
|
||||
-#ifdef __CURL_MULTI_H
|
||||
+#ifdef CURLINC_MULTI_H
|
||||
while(CURLM_CALL_MULTI_PERFORM ==
|
||||
curl_multi_perform(self->curlm, &remaining));
|
||||
RETVAL = remaining;
|
Loading…
Reference in a new issue