commit
aa06af37a1
2 changed files with 12 additions and 14 deletions
|
@ -8,14 +8,14 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=sumo
|
||||
PKG_VERSION:=0.27.1
|
||||
PKG_VERSION:=1.1.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-src-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/sumo
|
||||
PKG_HASH:=4494190bd6570646df7a020befe25bc66355377273d922753685737c0d38bfdf
|
||||
PKG_MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
|
||||
PKG_HASH:=68630b6879a3331683443e8044cb0a81e5919f9e4cfb80722933da85b84e542e
|
||||
|
||||
PKG_MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
|
||||
PKG_LICENSE:=GPL-3.0
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
||||
|
@ -25,20 +25,12 @@ PKG_INSTALL:=1
|
|||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--with-xerces=$(STAGING_DIR)/usr \
|
||||
--disable-debug \
|
||||
--disable-dependency-tracking \
|
||||
--disable-silent-rules
|
||||
|
||||
TARGET_CXXFLAGS+=-fpermissive
|
||||
|
||||
define Package/sumo
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
TITLE:=SUMO - Simulation of Urban MObility
|
||||
URL:=http://sumo-sim.org/
|
||||
DEPENDS:=+libstdcpp +libxerces-c
|
||||
URL:=https://sumo.dlr.de/
|
||||
DEPENDS:=+libxerces-c
|
||||
endef
|
||||
|
||||
define Package/sumo/description
|
||||
|
@ -50,6 +42,12 @@ define Package/sumo/description
|
|||
various APIs to remotely control the simulation.
|
||||
endef
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--with-xerces=$(STAGING_DIR)/usr \
|
||||
--disable-debug \
|
||||
--disable-dependency-tracking \
|
||||
--disable-silent-rules
|
||||
|
||||
define Package/sumo/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/{activitygen,dfrouter,duarouter,emissionsDrivingCycle,emissionsMap,jtrrouter,marouter,netconvert,netgenerate,od2trips,polyconvert,TraCITestClient} $(1)/usr/bin
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -117,11 +117,6 @@ dnl - - - - - - - - - - - - - - - - - -
|
||||
@@ -87,11 +87,6 @@ dnl - - - - - - - - - - - - - - - - - -
|
||||
case "$host" in
|
||||
x86-*-linux* | ia64-*-linux* | i586-*-linux* | i686-*-linux* | x86_64-*-linux*)
|
||||
dnl Make sure we are on architecture that supports SIMD
|
||||
|
|
Loading…
Reference in a new issue