pdns: fix compilation with boost 1.73
Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
03a27b26a4
commit
a9f9f6e0f4
2 changed files with 33 additions and 1 deletions
|
@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=pdns
|
PKG_NAME:=pdns
|
||||||
PKG_VERSION:=4.2.1
|
PKG_VERSION:=4.2.1
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=3
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=https://downloads.powerdns.com/releases/
|
PKG_SOURCE_URL:=https://downloads.powerdns.com/releases/
|
||||||
|
|
32
net/pdns/patches/300-boost-173.patch
Normal file
32
net/pdns/patches/300-boost-173.patch
Normal file
|
@ -0,0 +1,32 @@
|
||||||
|
--- a/pdns/ixfrdist-web.cc
|
||||||
|
+++ b/pdns/ixfrdist-web.cc
|
||||||
|
@@ -25,6 +25,8 @@
|
||||||
|
#include "iputils.hh"
|
||||||
|
#include "ixfrdist-stats.hh"
|
||||||
|
|
||||||
|
+using namespace boost::placeholders;
|
||||||
|
+
|
||||||
|
string doGetStats();
|
||||||
|
|
||||||
|
IXFRDistWebServer::IXFRDistWebServer(const ComboAddress &listenAddress, const NetmaskGroup &acl, const string &loglevel) :
|
||||||
|
--- a/pdns/webserver.cc
|
||||||
|
+++ b/pdns/webserver.cc
|
||||||
|
@@ -36,6 +36,8 @@
|
||||||
|
#include "uuid-utils.hh"
|
||||||
|
#include <yahttp/router.hpp>
|
||||||
|
|
||||||
|
+using namespace boost::placeholders;
|
||||||
|
+
|
||||||
|
json11::Json HttpRequest::json()
|
||||||
|
{
|
||||||
|
string err;
|
||||||
|
--- a/pdns/ws-auth.cc
|
||||||
|
+++ b/pdns/ws-auth.cc
|
||||||
|
@@ -49,6 +49,7 @@
|
||||||
|
#include "tsigutils.hh"
|
||||||
|
|
||||||
|
using json11::Json;
|
||||||
|
+using namespace boost::placeholders;
|
||||||
|
|
||||||
|
extern StatBag S;
|
||||||
|
|
Loading…
Reference in a new issue