pdns: fix compilation with boost 1.73

Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
Rosen Penev 2020-05-05 20:10:36 -07:00
parent 03a27b26a4
commit a9f9f6e0f4
No known key found for this signature in database
GPG key ID: 36D31CFA845F0E3B
2 changed files with 33 additions and 1 deletions

View file

@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=pdns
PKG_VERSION:=4.2.1
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://downloads.powerdns.com/releases/

View file

@ -0,0 +1,32 @@
--- a/pdns/ixfrdist-web.cc
+++ b/pdns/ixfrdist-web.cc
@@ -25,6 +25,8 @@
#include "iputils.hh"
#include "ixfrdist-stats.hh"
+using namespace boost::placeholders;
+
string doGetStats();
IXFRDistWebServer::IXFRDistWebServer(const ComboAddress &listenAddress, const NetmaskGroup &acl, const string &loglevel) :
--- a/pdns/webserver.cc
+++ b/pdns/webserver.cc
@@ -36,6 +36,8 @@
#include "uuid-utils.hh"
#include <yahttp/router.hpp>
+using namespace boost::placeholders;
+
json11::Json HttpRequest::json()
{
string err;
--- a/pdns/ws-auth.cc
+++ b/pdns/ws-auth.cc
@@ -49,6 +49,7 @@
#include "tsigutils.hh"
using json11::Json;
+using namespace boost::placeholders;
extern StatBag S;