zmq: update to trunk version
Signed-off-by: John Crispin <blogic@openwrt.org>
This commit is contained in:
parent
50b79a9e86
commit
a93c172c71
4 changed files with 53 additions and 6 deletions
|
@ -10,8 +10,8 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=zeromq
|
||||
PKG_VERSION:=4.0.5
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=4.1.1
|
||||
PKG_RELEASE:=1
|
||||
PKG_MAINTAINER:=Dirk Chang <dirk@kooiot.com>
|
||||
PKG_LICENSE:=GPL-3.0+
|
||||
PKG_LICENSE_FILES:=LICENCE.txt
|
||||
|
@ -58,6 +58,12 @@ CONFIGURE_ARGS += \
|
|||
--enable-static \
|
||||
--enable-shared
|
||||
|
||||
ifneq ($(CONFIG_PACKAGE_libsodium),)
|
||||
CONFIGURE_ARGS+= --with-libsodium
|
||||
else
|
||||
CONFIGURE_ARGS+= --without-libsodium
|
||||
endif
|
||||
|
||||
# add make variable overrides here
|
||||
MAKE_FLAGS +=
|
||||
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- zeromq-4.0.4_org/configure.ac 2014-06-04 10:19:35.140061796 +0800
|
||||
+++ zeromq-4.0.4/configure.ac 2014-06-04 11:08:17.231997926 +0800
|
||||
--- a/configure.ac 2014-06-04 10:19:35.140061796 +0800
|
||||
+++ b/configure.ac 2014-06-04 11:08:17.231997926 +0800
|
||||
@@ -127,8 +127,10 @@
|
||||
*linux*)
|
||||
# Define on Linux to enable all library features. Define if using a gnu compiler
|
||||
|
|
41
libs/zmq/patches/map_with_const_string_with_ublic++.patch
Normal file
41
libs/zmq/patches/map_with_const_string_with_ublic++.patch
Normal file
|
@ -0,0 +1,41 @@
|
|||
--- a/src/metadata.hpp 2015-06-17 21:39:33.629934688 +0800
|
||||
+++ b/src/metadata.hpp 2014-10-14 22:07:36.000000000 +0800
|
||||
@@ -31,7 +31,7 @@
|
||||
{
|
||||
public:
|
||||
|
||||
- typedef std::map <std::string, const std::string> dict_t;
|
||||
+ typedef std::map <std::string, std::string> dict_t;
|
||||
|
||||
metadata_t (const dict_t &dict);
|
||||
virtual ~metadata_t ();
|
||||
--- a/src/socket_base.cpp 2015-06-17 21:42:26.289413233 +0800
|
||||
+++ b/src/socket_base.cpp 2015-06-02 18:31:00.000000000 +0800
|
||||
@@ -20,6 +20,7 @@
|
||||
#include <new>
|
||||
#include <string>
|
||||
#include <algorithm>
|
||||
+#include <ctype.h>
|
||||
|
||||
#include "platform.hpp"
|
||||
|
||||
--- a/src/stream_engine.cpp 2015-06-17 21:57:29.599443517 +0800
|
||||
+++ b/src/stream_engine.cpp 2015-06-02 18:31:00.000000000 +0800
|
||||
@@ -198,7 +198,7 @@
|
||||
// Compile metadata.
|
||||
typedef metadata_t::dict_t properties_t;
|
||||
properties_t properties;
|
||||
- properties.insert(std::make_pair("Peer-Address", peer_address));
|
||||
+ properties.insert(std::make_pair<std::string, std::string>("Peer-Address", peer_address));
|
||||
zmq_assert (metadata == NULL);
|
||||
metadata = new (std::nothrow) metadata_t (properties);
|
||||
}
|
||||
@@ -805,7 +805,7 @@
|
||||
|
||||
// If we have a peer_address, add it to metadata
|
||||
if (!peer_address.empty()) {
|
||||
- properties.insert(std::make_pair("Peer-Address", peer_address));
|
||||
+ properties.insert(std::make_pair<std::string, std::string>("Peer-Address", peer_address));
|
||||
}
|
||||
|
||||
// Add ZAP properties.
|
|
@ -1,5 +1,5 @@
|
|||
--- zeromq-4.0.4_org/src/blob.hpp 2014-06-04 10:19:12.680062287 +0800
|
||||
+++ zeromq-4.0.4/src/blob.hpp 2014-06-04 10:30:31.168047457 +0800
|
||||
--- a/src/blob.hpp 2014-06-04 10:19:12.680062287 +0800
|
||||
+++ b/src/blob.hpp 2014-06-04 10:30:31.168047457 +0800
|
||||
@@ -21,6 +21,7 @@
|
||||
#define __ZMQ_BLOB_HPP_INCLUDED__
|
||||
|
||||
|
|
Loading…
Reference in a new issue