softethervpn5: update to 5.01.9672
* 5.01.9672 release * Cedar: handle UDP acceleration and R-UDP versions * Mayaqua: implement R-UDP version 2, powered by ChaCha20-Poly1305 * Cedar: implement UDP acceleration version 2, powered by ChaCha20-Poly1305 * Cedar: serve new web management interface * Cedar: implement detailed protocol info * Mayaqua: add Windows Server 2019 to the supported operating systems list * Cedar: various fixes * Cedar: add "DisableIPsecAggressiveMode" option * Make install dir for unit files configurable * Protocol.c: adapt ClientConnectGetSocket() for new proxy functions * Wpc.c: adapt WpcSockConnectEx() for new proxy functions * Protocol: add ProxyCodeToCedar() * Move generic proxy stuff from Cedar to Mayaqua * Proto_OpenVPN.c: improve OvsProcessData(), fix out-of-bounds access found by Coverity * Proto_OpenVPN.c: fix segmentation fault in OvsProceccRecvPacket() * Addressing the UDP reflection amplification attack: https://github.com/SoftEtherVPN/SoftEtherVPN/issues/1001 * Mayaqua.h: include <stdarg.h> for "va_list" on Illumos * Protocol.c: fix bug in ClientConnectGetSocket() causing custom HTTP header not to work * Mayaqua: move HTTP functions from "Network" to "HTTP" * Move GetMimeTypeFromFileName() and related structure to Mayaqua * Mayaqua.h: include <stdio.h> for "FILE" * Mayaqua.h: include <stddef.h>, for "wchar_t" * Bump mixin-deep in /src/bin/hamcore/wwwroot/admin/default * - Fixed the problem occurs when RPC messages between Cluster Members exceed 64Kbytes. - Fixed the RADIUS PEAP client to use the standard TLS versioning. - Implementation of a function to fix the MAC address of L3 VPN protocol by entering e.g. "MAC: 112233445566" in the "Notes" field of the user information. - Implementation of a function to fix the virtual MAC address to be assigned to the L3 VPN client as a string attribute from RADIUS server when authentication. * Updating built-in Win32 libraries - OpenSSL 1.1.1 -> 1.1.1d - zlib 1.2.3 -> 1.2.11 * Update strtable_cn.stb * Avoid using hardcoded paths in log file enumeration * Fix buffer overflow during NETBIOS name resolution * Update SEVPN.sln * Create strtable_pt_br.stb * ci: display error if vpntest failed * Fix several compile warnings on MS VC++ 2008. * Enables crash minidump for Win32 vpntest. Minidump files will be saved to the 'C:\Users\<username>\AppData\Local\Temp\vpn_debug' (for normal user) or 'src\bin\vpn_debug\' (for administrator user). * OpenVPN: use new protocol interface * Add interface for easy protocol implementation * add "no-deprecated" to openssl builds "no-deprecated" is widely used in openwrt devices * Fix LibreSSL support * Switch to OpenSSL THREADID API * travis-ci: update openssl, libressl * enable sonar-scan in travis-ci builds * Virtual: fix race condition in DHCP server which resulted in multiple clients receiving the same IP * Mayaqua: Fix compilation without deprecated OpenSSL APIs * Mayaqua: Replace GNU specific sys/poll.h header with POSIX poll.h * systemd: replace deprecated CAP_SYS_ADMIN with CAP_SYSLOG Signed-off-by: Andy Walsh <andy.walsh44+github@gmail.com>
This commit is contained in:
parent
21c52897bd
commit
a881ab43c9
4 changed files with 2 additions and 29 deletions
|
@ -3,7 +3,7 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=softethervpn5
|
||||
PKG_VERSION:=5.01.9671
|
||||
PKG_VERSION:=5.01.9672
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_MAINTAINER:=Andy Walsh <andy.walsh44+github@gmail.com>
|
||||
|
@ -12,7 +12,7 @@ PKG_LICENSE_FILES:=COPYING
|
|||
|
||||
PKG_SOURCE_URL:=https://github.com/SoftEtherVPN/SoftEtherVPN/releases/download/$(PKG_VERSION)/
|
||||
PKG_SOURCE:=softether-vpn-src-$(PKG_VERSION).tar.gz
|
||||
PKG_HASH:=56930110ad5e21a3b7c69008bdb3efd368c0ebafc1d0d97b48a76a3563ec8e24
|
||||
PKG_HASH:=7c437d4d02d7e2a936b4c1ff7bc8f5abbf16786746deffa92d5f5f2fd7ba04fb
|
||||
|
||||
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/SoftEtherVPN-$(PKG_VERSION)
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/SoftEtherVPN-$(PKG_VERSION)
|
||||
|
|
|
@ -1,27 +0,0 @@
|
|||
From a4ed6560017d0b9edcd7cab93ca05d80f794ec10 Mon Sep 17 00:00:00 2001
|
||||
From: Rosen Penev <rosenp@gmail.com>
|
||||
Date: Wed, 10 Jul 2019 17:01:01 -0700
|
||||
Subject: [PATCH] Mayaqua: Replace GNU specific sys/poll.h header with POSIX
|
||||
poll.h
|
||||
|
||||
Fixes warning from the musl libc:
|
||||
|
||||
warning redirecting incorrect #include <sys/poll.h> to <poll.h>
|
||||
---
|
||||
src/Mayaqua/Mayaqua.h | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/Mayaqua/Mayaqua.h b/src/Mayaqua/Mayaqua.h
|
||||
index 0f46d52a..63c2edc3 100644
|
||||
--- a/src/Mayaqua/Mayaqua.h
|
||||
+++ b/src/Mayaqua/Mayaqua.h
|
||||
@@ -157,8 +157,8 @@ int PASCAL WinMain(HINSTANCE hInst, HINSTANCE hPrev, char *CmdLine, int CmdShow)
|
||||
#ifdef UNIX_SOLARIS
|
||||
#include <sys/filio.h>
|
||||
#endif // UNIX_SOLARIS
|
||||
-#include <sys/poll.h>
|
||||
#include <sys/resource.h>
|
||||
+#include <poll.h>
|
||||
#include <pthread.h>
|
||||
#ifdef UNIX_LINUX
|
||||
#include <sys/prctl.h>
|
Loading…
Reference in a new issue