zerotier: update to 1.10.2
Signed-off-by: Moritz Warning <moritzwarning@web.de>
This commit is contained in:
parent
8aec58f78c
commit
a74d1b82ef
4 changed files with 30 additions and 61 deletions
|
@ -6,12 +6,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=zerotier
|
||||
PKG_VERSION:=1.8.6
|
||||
PKG_VERSION:=1.10.2
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/zerotier/ZeroTierOne/tar.gz/$(PKG_VERSION)?
|
||||
PKG_HASH:=40dce71426f2649e5159854c37560f5a0b634c23d4774453dae0b7ef620af22a
|
||||
PKG_HASH:=9f98b1670785f42294b9858068d42c6b8c2fdee6402e871a36562b47559e74e7
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/ZeroTierOne-$(PKG_VERSION)
|
||||
|
||||
PKG_MAINTAINER:=Moritz Warning <moritzwarning@web.de>
|
||||
|
@ -45,6 +45,8 @@ MAKE_FLAGS += ZT_DEBUG=1
|
|||
endif
|
||||
|
||||
MAKE_FLAGS += \
|
||||
ZT_EMBEDDED=1 \
|
||||
ZT_SSO_SUPPORTED=0 \
|
||||
DEFS="" \
|
||||
OSTYPE="Linux" \
|
||||
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
From 4965b6d10b2f51f4b30a8c0a8f3a64cf48dea635 Mon Sep 17 00:00:00 2001
|
||||
From 2c513f0db50eaee5623d58ac024d62142f4ac782 Mon Sep 17 00:00:00 2001
|
||||
From: Moritz Warning <moritzwarning@web.de>
|
||||
Date: Tue, 8 Mar 2022 19:09:47 +0100
|
||||
Subject: [PATCH 1/3] fix makefile
|
||||
Date: Mon, 4 Jul 2022 00:09:24 +0200
|
||||
Subject: [PATCH 1/2] fix makefile
|
||||
|
||||
---
|
||||
make-linux.mk | 8 ++++----
|
||||
1 file changed, 4 insertions(+), 4 deletions(-)
|
||||
make-linux.mk | 14 +++++++-------
|
||||
1 file changed, 7 insertions(+), 7 deletions(-)
|
||||
|
||||
--- a/make-linux.mk
|
||||
+++ b/make-linux.mk
|
||||
|
@ -21,7 +21,7 @@ Subject: [PATCH 1/3] fix makefile
|
|||
override DEFS+=-DZT_USE_SYSTEM_MINIUPNPC
|
||||
LDLIBS+=-lminiupnpc
|
||||
@@ -34,7 +34,7 @@ else
|
||||
override DEFS+=-DMINIUPNP_STATICLIB -DMINIUPNPC_SET_SOCKET_TIMEOUT -DMINIUPNPC_GET_SRC_ADDR -D_BSD_SOURCE -D_DEFAULT_SOURCE -D_XOPEN_SOURCE=600 -DOS_STRING=\"Linux\" -DMINIUPNPC_VERSION_STRING=\"2.0\" -DUPNP_VERSION_STRING=\"UPnP/1.1\" -DENABLE_STRNATPMPERR
|
||||
override DEFS+=-DMINIUPNP_STATICLIB -DMINIUPNPC_SET_SOCKET_TIMEOUT -DMINIUPNPC_GET_SRC_ADDR -D_BSD_SOURCE -D_DEFAULT_SOURCE -D_XOPEN_SOURCE=600 -DOS_STRING="\"Linux\"" -DMINIUPNPC_VERSION_STRING="\"2.0\"" -DUPNP_VERSION_STRING="\"UPnP/1.1\"" -DENABLE_STRNATPMPERR
|
||||
ONE_OBJS+=ext/miniupnpc/connecthostport.o ext/miniupnpc/igd_desc_parse.o ext/miniupnpc/minisoap.o ext/miniupnpc/minissdpc.o ext/miniupnpc/miniupnpc.o ext/miniupnpc/miniwget.o ext/miniupnpc/minixml.o ext/miniupnpc/portlistingparse.o ext/miniupnpc/receivedata.o ext/miniupnpc/upnpcommands.o ext/miniupnpc/upnpdev.o ext/miniupnpc/upnperrors.o ext/miniupnpc/upnpreplyparse.o
|
||||
endif
|
||||
-ifeq ($(wildcard /usr/include/natpmp.h),)
|
||||
|
@ -29,22 +29,16 @@ Subject: [PATCH 1/3] fix makefile
|
|||
ONE_OBJS+=ext/libnatpmp/natpmp.o ext/libnatpmp/getgateway.o
|
||||
else
|
||||
LDLIBS+=-lnatpmp
|
||||
@@ -66,11 +66,11 @@ ifeq ($(ZT_DEBUG),1)
|
||||
# C25519 in particular is almost UNUSABLE in -O0 even on a 3ghz box!
|
||||
node/Salsa20.o node/SHA512.o node/C25519.o node/Poly1305.o: CXXFLAGS=-Wall -O2 -g -pthread $(INCLUDES) $(DEFS)
|
||||
else
|
||||
- CFLAGS?=-O3 -fstack-protector -fPIE
|
||||
+ CFLAGS?=-O3 -fstack-protector
|
||||
@@ -70,7 +70,7 @@ else
|
||||
override CFLAGS+=-Wall -Wno-deprecated -pthread $(INCLUDES) -DNDEBUG $(DEFS)
|
||||
- CXXFLAGS?=-O3 -fstack-protector -fPIE
|
||||
+ CXXFLAGS?=-O3 -fstack-protector
|
||||
override CXXFLAGS+=-Wall -Wno-deprecated -std=c++11 -pthread $(INCLUDES) -DNDEBUG $(DEFS)
|
||||
CXXFLAGS?=-O3 -fstack-protector
|
||||
override CXXFLAGS+=-Wall -Wno-deprecated -std=c++17 -pthread $(INCLUDES) -DNDEBUG $(DEFS)
|
||||
- LDFLAGS=-pie -Wl,-z,relro,-z,now
|
||||
+ LDFLAGS+=-Wl,-z,relro,-z,now
|
||||
+ LDFLAGS=-Wl,-z,relro,-z,now
|
||||
RUSTFLAGS=--release
|
||||
endif
|
||||
|
||||
@@ -300,7 +300,7 @@ ifeq ($(ZT_CONTROLLER),1)
|
||||
@@ -308,7 +308,7 @@ ifeq ($(ZT_CONTROLLER),1)
|
||||
endif
|
||||
|
||||
# ARM32 hell -- use conservative CFLAGS
|
||||
|
@ -53,3 +47,14 @@ Subject: [PATCH 1/3] fix makefile
|
|||
ifeq ($(shell if [ -e /usr/bin/dpkg ]; then dpkg --print-architecture; fi),armel)
|
||||
override CFLAGS+=-march=armv5t -mfloat-abi=soft -msoft-float -mno-unaligned-access -marm
|
||||
override CXXFLAGS+=-march=armv5t -mfloat-abi=soft -msoft-float -mno-unaligned-access -marm
|
||||
@@ -335,8 +335,8 @@ ifeq ($(ZT_USE_ARM32_NEON_ASM_CRYPTO),1)
|
||||
endif
|
||||
|
||||
# Position Independence
|
||||
-override CFLAGS+=-fPIC -fPIE
|
||||
-override CXXFLAGS+=-fPIC -fPIE
|
||||
+#override CFLAGS+=-fPIC -fPIE
|
||||
+#override CXXFLAGS+=-fPIC -fPIE
|
||||
|
||||
.PHONY: all
|
||||
all: one
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 8c24328d41a3a25db3b3d73baf86ed2c71160774 Mon Sep 17 00:00:00 2001
|
||||
From 819232a2b5a09d7aa3cacb8dcf7c2e28afde1b06 Mon Sep 17 00:00:00 2001
|
||||
From: Moritz Warning <moritzwarning@web.de>
|
||||
Date: Mon, 30 Nov 2020 12:25:42 +0100
|
||||
Subject: [PATCH 2/3] fix compilation for arm_cortex-a7+neon
|
||||
Date: Mon, 4 Jul 2022 00:10:52 +0200
|
||||
Subject: [PATCH 2/2] fix compilation for arm_cortex-a7+neon
|
||||
|
||||
Fixes "error: 'vrbitq_u8' was not declared in this scope"
|
||||
|
||||
|
@ -12,7 +12,7 @@ Signed-off-by: Rosen Penev <rosenp@gmail.com>
|
|||
|
||||
--- a/node/Constants.hpp
|
||||
+++ b/node/Constants.hpp
|
||||
@@ -118,7 +118,7 @@
|
||||
@@ -123,7 +123,7 @@
|
||||
#include <immintrin.h>
|
||||
#endif
|
||||
|
||||
|
|
|
@ -1,38 +0,0 @@
|
|||
From 826718bdbbd42fcf56bdb45dd9e71af10299cfa3 Mon Sep 17 00:00:00 2001
|
||||
From: Oskari Rauta <oskari.rauta@gmail.com>
|
||||
Date: Sun, 13 Mar 2022 10:06:08 +0100
|
||||
Subject: [PATCH 3/3] do not use zt SSO and OIDC
|
||||
|
||||
These features need Rust/Cargo support
|
||||
in the build system. OpenWrt does not
|
||||
have that yet.
|
||||
---
|
||||
make-linux.mk | 4 ++++
|
||||
node/Constants.hpp | 3 +++
|
||||
2 files changed, 7 insertions(+)
|
||||
|
||||
--- a/make-linux.mk
|
||||
+++ b/make-linux.mk
|
||||
@@ -268,6 +268,10 @@ ifeq ($(ZT_IA32),1)
|
||||
endif
|
||||
|
||||
ifeq ($(ZT_SSO_SUPPORTED), 1)
|
||||
+ ZT_SSO_SUPPORTED=0
|
||||
+endif
|
||||
+
|
||||
+ifeq ($(ZT_SSO_SUPPORTED), 1)
|
||||
ifeq ($(ZT_DEBUG),1)
|
||||
LDLIBS+=zeroidc/target/debug/libzeroidc.a -ldl -lssl -lcrypto
|
||||
else
|
||||
--- a/node/Constants.hpp
|
||||
+++ b/node/Constants.hpp
|
||||
@@ -72,6 +72,9 @@
|
||||
#include <machine/endian.h>
|
||||
#endif
|
||||
|
||||
+#undef OIDC_SUPPORTED
|
||||
+#define OIDC_SUPPORTED 0
|
||||
+
|
||||
#if defined(__FreeBSD__) || defined(__OpenBSD__) || defined(__NetBSD__)
|
||||
#define OIDC_SUPPORTED 0
|
||||
#ifndef __UNIX_LIKE__
|
Loading…
Reference in a new issue