perl: remove build timestamp
Build timestamp prevents reproducible builds [0]. [0] https://reproducible-builds.org/docs/timestamps/ Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
This commit is contained in:
parent
f3d0d51e96
commit
a73e96cb0c
2 changed files with 22 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=perl
|
PKG_NAME:=perl
|
||||||
PKG_VERSION:=5.26.1
|
PKG_VERSION:=5.26.1
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=2
|
||||||
|
|
||||||
PKG_SOURCE_URL:=\
|
PKG_SOURCE_URL:=\
|
||||||
https://cpan.metacpan.org/src/5.0 \
|
https://cpan.metacpan.org/src/5.0 \
|
||||||
|
|
21
lang/perl/patches/120-remove-build-timestamp.patch
Normal file
21
lang/perl/patches/120-remove-build-timestamp.patch
Normal file
|
@ -0,0 +1,21 @@
|
||||||
|
Index: perl-5.26.1/perl.c
|
||||||
|
===================================================================
|
||||||
|
--- perl-5.26.1.orig/perl.c
|
||||||
|
+++ perl-5.26.1/perl.c
|
||||||
|
@@ -1870,16 +1870,6 @@ S_Internals_V(pTHX_ CV *cv)
|
||||||
|
PUSHs(Perl_newSVpvn_flags(aTHX_ non_bincompat_options,
|
||||||
|
sizeof(non_bincompat_options) - 1, SVs_TEMP));
|
||||||
|
|
||||||
|
-#ifndef PERL_BUILD_DATE
|
||||||
|
-# ifdef __DATE__
|
||||||
|
-# ifdef __TIME__
|
||||||
|
-# define PERL_BUILD_DATE __DATE__ " " __TIME__
|
||||||
|
-# else
|
||||||
|
-# define PERL_BUILD_DATE __DATE__
|
||||||
|
-# endif
|
||||||
|
-# endif
|
||||||
|
-#endif
|
||||||
|
-
|
||||||
|
#ifdef PERL_BUILD_DATE
|
||||||
|
PUSHs(Perl_newSVpvn_flags(aTHX_
|
||||||
|
STR_WITH_LEN("Compiled at " PERL_BUILD_DATE),
|
Loading…
Reference in a new issue