samplicator: update to latest master commit 2021-10-11
The newest master branch has important fixes. However, no new release is published [0]. Switch to git and update to latest master commit. This introduces new version scheme by using YYYY-MM-DD of the commit. In addition, add necessary "PKG_FIXUP" and "PKG_REMOVE_FILES" to allow compile the new version. Also add enable "PKG_BUILD_PARALLEL". Further, use a pidfile and remove outdated patches. https://github.com/sleinen/samplicator/issues/73 Signed-off-by: Nick Hainke <vincent@systemli.org>
This commit is contained in:
parent
4c8e9ad20c
commit
a6d7ed4d6d
3 changed files with 11 additions and 16 deletions
|
@ -1,17 +1,22 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=samplicator
|
PKG_NAME:=samplicator
|
||||||
PKG_VERSION:=1.3.6
|
|
||||||
PKG_RELEASE:=$(AUTORELEASE)
|
PKG_RELEASE:=$(AUTORELEASE)
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE_PROTO:=git
|
||||||
PKG_SOURCE_URL:=https://github.com/sleinen/samplicator/releases/download/v$(PKG_VERSION)
|
PKG_SOURCE_URL:=https://github.com/sleinen/samplicator.git
|
||||||
PKG_HASH:=3c4358b4b0992a77251f2b9e2221d4ae945781160732c73504eb126e69d72d40
|
PKG_SOURCE_DATE:=2021-10-11
|
||||||
|
PKG_SOURCE_VERSION:=ceeb1d280188c155b71d819282490be86190f6f6
|
||||||
|
PKG_MIRROR_HASH:=e96ac711313d3554d53ca8de5061b8fb18dfeb2823c4c0fe3404ba3b71e8b689
|
||||||
|
|
||||||
PKG_MAINTAINER:=Nick Hainke <vincent@systemli.org>
|
PKG_MAINTAINER:=Nick Hainke <vincent@systemli.org>
|
||||||
PKG_LICENSE:=GPL-2.0-only
|
PKG_LICENSE:=GPL-2.0-only
|
||||||
PKG_LICENSE_FILES:=COPYING
|
PKG_LICENSE_FILES:=COPYING
|
||||||
|
|
||||||
|
PKG_FIXUP:=autoreconf
|
||||||
|
PKG_REMOVE_FILES:=autogen.sh
|
||||||
|
PKG_BUILD_PARALLEL:=1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
define Package/samplicator
|
define Package/samplicator
|
||||||
|
|
|
@ -5,11 +5,12 @@ START=70
|
||||||
|
|
||||||
SAMPLICATOR_BIN="/usr/sbin/samplicate"
|
SAMPLICATOR_BIN="/usr/sbin/samplicate"
|
||||||
SAMPLICATOR_CONF="/etc/samplicator.conf"
|
SAMPLICATOR_CONF="/etc/samplicator.conf"
|
||||||
|
PIDFILE="/var/run/samplicator.pid"
|
||||||
|
|
||||||
start_service() {
|
start_service() {
|
||||||
mkdir -p /var/run
|
mkdir -p /var/run
|
||||||
procd_open_instance
|
procd_open_instance
|
||||||
procd_set_param command $SAMPLICATOR_BIN -c $SAMPLICATOR_CONF
|
procd_set_param command $SAMPLICATOR_BIN -c $SAMPLICATOR_CONF -m $PIDFILE
|
||||||
procd_set_param file "$SAMPLICATOR_CONF"
|
procd_set_param file "$SAMPLICATOR_CONF"
|
||||||
procd_set_param stdout 1
|
procd_set_param stdout 1
|
||||||
procd_set_param stderr 1
|
procd_set_param stderr 1
|
||||||
|
|
|
@ -1,11 +0,0 @@
|
||||||
--- a/samplicate.c
|
|
||||||
+++ b/samplicate.c
|
|
||||||
@@ -560,7 +560,7 @@ samplicate (ctx)
|
|
||||||
}
|
|
||||||
if (len != sizeof remote_address)
|
|
||||||
{
|
|
||||||
- fprintf (stderr, "recvfrom() return address length %d - expected %d\n",
|
|
||||||
+ fprintf (stderr, "recvfrom() return address length %d - expected %zu\n",
|
|
||||||
len, sizeof remote_address);
|
|
||||||
exit (1);
|
|
||||||
}
|
|
Loading…
Reference in a new issue