horst: remove build time to fix reproducible builds
Build timestamp are not reproducible [0]. [0] https://reproducible-builds.org/docs/timestamps/ Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
This commit is contained in:
parent
a2de0d04b4
commit
a6d437c40e
2 changed files with 27 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=horst
|
||||
PKG_VERSION:=5.1
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://github.com/br101/horst/archive/v$(PKG_VERSION)/
|
||||
|
|
26
net/horst/patches/0001-reproducible-builds.patch
Normal file
26
net/horst/patches/0001-reproducible-builds.patch
Normal file
|
@ -0,0 +1,26 @@
|
|||
Index: horst-5.1/conf_options.c
|
||||
===================================================================
|
||||
--- horst-5.1.orig/conf_options.c
|
||||
+++ horst-5.1/conf_options.c
|
||||
@@ -519,7 +519,7 @@ void config_parse_file_and_cmdline(int a
|
||||
conf_filename = optarg;
|
||||
break;
|
||||
case 'v':
|
||||
- printf("%s (build date: %s %s)\n", VERSION, __DATE__, __TIME__);
|
||||
+ printf("%s\n", VERSION);
|
||||
exit(0);
|
||||
case 'h':
|
||||
case '?':
|
||||
Index: horst-5.1/display-help.c
|
||||
===================================================================
|
||||
--- horst-5.1.orig/display-help.c
|
||||
+++ horst-5.1/display-help.c
|
||||
@@ -36,7 +36,7 @@ void update_help_win(WINDOW *win)
|
||||
print_centered(win, 2, COLS, "HORST - Horsts OLSR Radio Scanning Tool (or)");
|
||||
print_centered(win, 3, COLS, "HORST - Highly Optimized Radio Scanning Tool");
|
||||
|
||||
- print_centered(win, 5, COLS, "Version " VERSION " (build date " __DATE__ " " __TIME__ ")");
|
||||
+ print_centered(win, 5, COLS, "Version " VERSION);
|
||||
print_centered(win, 6, COLS, "(C) 2005-2016 Bruno Randolf, Licensed under the GPLv2");
|
||||
|
||||
mvwprintw(win, 8, 2, "Known IEEE802.11 Packet Types:");
|
Loading…
Reference in a new issue