v3l2rtspserver: update to 0.23
Update live555 as well. Switch to building with ninja for faster compilation. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
6fa328d109
commit
a654190cb0
2 changed files with 6 additions and 50 deletions
|
@ -7,28 +7,25 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=v4l2rtspserver
|
||||
PKG_VERSION:=0.2.1
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=0.2.3
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
#cannot use codeload as this uses submodules
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://github.com/mpromonet/v4l2rtspserver
|
||||
PKG_SOURCE_VERSION:=v$(PKG_VERSION)
|
||||
PKG_MIRROR_HASH:=ddc4217ee12e57a4c248b6667309559323458028dc0fa085942b91dbbcd74146
|
||||
PKG_MIRROR_HASH:=f047fd24441a070b123252bf82c7d7e42bb0c3280b78ad2ddb01cf200acc3a32
|
||||
|
||||
LIVE555_VERSION:=2020.11.29
|
||||
LIVE555_HASH:=0300f1f0b92529909623d3e870edeadff9841bbc9097a481a8583c5b9a6cc3ae
|
||||
LIVE555_VERSION:=2021.02.11
|
||||
LIVE555_HASH:=834ad3fc199f1a6b0c09646976deb71a3a7803dc7b498ce92e920f6cb7b717ba
|
||||
LIVE555_FILE:=live.$(LIVE555_VERSION).tar.gz
|
||||
|
||||
PKG_MAINTAINER:=Roger Dammit <rogerdammit@gmail.com>
|
||||
PKG_LICENSE:=Unlicense
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
CMAKE_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/cmake.mk
|
||||
include ../../devel/ninja/ninja-cmake.mk
|
||||
|
||||
define Package/v4l2rtspserver
|
||||
SECTION:=multimedia
|
||||
|
|
|
@ -1,41 +0,0 @@
|
|||
From f0f04b7315f59b3a9b814c13c705d4354d0c0626 Mon Sep 17 00:00:00 2001
|
||||
From: mpromonet <michel.promonet@free.fr>
|
||||
Date: Fri, 27 Nov 2020 19:36:43 +0100
|
||||
Subject: [PATCH] fix #216: allow to build with live555 newer than 2020.11.27
|
||||
(2020.11.25 & 2020.11.26 doesnot build)
|
||||
|
||||
---
|
||||
inc/HTTPServer.h | 9 +++++++--
|
||||
1 file changed, 7 insertions(+), 2 deletions(-)
|
||||
|
||||
--- a/inc/HTTPServer.h
|
||||
+++ b/inc/HTTPServer.h
|
||||
@@ -113,13 +113,18 @@ class TCPSink: public MediaSink {
|
||||
// ---------------------------------------------------------
|
||||
// Extend RTSP server to add support for HLS and MPEG-DASH
|
||||
// ---------------------------------------------------------
|
||||
+#if LIVEMEDIA_LIBRARY_VERSION_INT < 1606435200
|
||||
+#define SOCKETCLIENT sockaddr_in
|
||||
+#else
|
||||
+#define SOCKETCLIENT sockaddr_storage
|
||||
+#endif
|
||||
class HTTPServer : public RTSPServer
|
||||
{
|
||||
|
||||
class HTTPClientConnection : public RTSPServer::RTSPClientConnection
|
||||
{
|
||||
public:
|
||||
- HTTPClientConnection(RTSPServer& ourServer, int clientSocket, struct sockaddr_in clientAddr)
|
||||
+ HTTPClientConnection(RTSPServer& ourServer, int clientSocket, struct SOCKETCLIENT clientAddr)
|
||||
: RTSPServer::RTSPClientConnection(ourServer, clientSocket, clientAddr), m_TCPSink(NULL), m_StreamToken(NULL), m_Subsession(NULL), m_Source(NULL) {
|
||||
}
|
||||
virtual ~HTTPClientConnection();
|
||||
@@ -165,7 +170,7 @@ class HTTPServer : public RTSPServer
|
||||
}
|
||||
}
|
||||
|
||||
- RTSPServer::RTSPClientConnection* createNewClientConnection(int clientSocket, struct sockaddr_in clientAddr)
|
||||
+ RTSPServer::RTSPClientConnection* createNewClientConnection(int clientSocket, struct SOCKETCLIENT clientAddr)
|
||||
{
|
||||
return new HTTPClientConnection(*this, clientSocket, clientAddr);
|
||||
}
|
Loading…
Reference in a new issue