python-parsley: new package
From the setup description: Parsing and pattern matching made easy. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
This commit is contained in:
parent
6ceee2c0dd
commit
a6439b9664
2 changed files with 55 additions and 0 deletions
43
lang/python-parsley/Makefile
Normal file
43
lang/python-parsley/Makefile
Normal file
|
@ -0,0 +1,43 @@
|
|||
#
|
||||
# Copyright (C) 2015 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=Parsley
|
||||
PKG_VERSION:=1.3
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://pypi.python.org/packages/source/P/Parsley
|
||||
PKG_MD5SUM:=92bc256e5f73810a609dc7874637ad31
|
||||
|
||||
PKG_LICENSE:=MIT
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
$(call include_mk, python-package.mk)
|
||||
|
||||
define Package/python-parsley
|
||||
SECTION:=lang
|
||||
CATEGORY:=Languages
|
||||
SUBMENU:=Python
|
||||
TITLE:=python-parsley
|
||||
URL:=http://launchpad.net/parsley
|
||||
DEPENDS:=+python-light
|
||||
endef
|
||||
|
||||
define Package/python-parsley/description
|
||||
Parsing and pattern matching made easy.
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(call Build/Compile/PyMod,,install --prefix="/usr" --root="$(PKG_INSTALL_DIR)")
|
||||
endef
|
||||
|
||||
$(eval $(call PyPackage,python-parsley))
|
||||
$(eval $(call BuildPackage,python-parsley))
|
12
lang/python-parsley/patches/001-omit-tests.patch
Normal file
12
lang/python-parsley/patches/001-omit-tests.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
diff -Nur a/setup.py b/setup.py
|
||||
--- a/setup.py 2015-09-09 10:45:25.000000000 +0800
|
||||
+++ b/setup.py 2015-12-01 17:31:03.143409843 +0800
|
||||
@@ -14,7 +14,6 @@
|
||||
author_email="washort42@gmail.com",
|
||||
license="MIT License",
|
||||
long_description=open("README").read(),
|
||||
- packages=["ometa", "terml", "ometa._generated", "terml._generated",
|
||||
- "ometa.test", "terml.test"],
|
||||
+ packages=["ometa", "terml", "ometa._generated", "terml._generated"],
|
||||
py_modules=["parsley"]
|
||||
)
|
Loading…
Reference in a new issue