apr-util: clean up Makefile and remove patch
- removes 001-automake-compat.patch: Looks like this was meant as a workaround for a libtool issue. But it doesn't appear to be needed anymore. - cleans up installation defines (uses macros, cleans up sed scripts, removes gratuitous slashes & whitespaces) Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
This commit is contained in:
parent
193c3913b6
commit
a62c0e599b
2 changed files with 14 additions and 39 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=apr-util
|
||||
PKG_VERSION:=1.6.1
|
||||
PKG_RELEASE:=4
|
||||
PKG_RELEASE:=5
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=@APACHE/apr/
|
||||
|
@ -127,30 +127,26 @@ $$(eval $$(call BuildPackage,libaprutil-$(subst _,-,$(1))))
|
|||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/bin $(1)/usr/include/apr-1/ $(1)/usr/lib $(1)/usr/lib/pkgconfig/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/apu-1-config \
|
||||
$(1)/usr/bin/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/apr-1/* \
|
||||
$(1)/usr/include/apr-1/
|
||||
$(INSTALL_DIR) $(1)/usr/bin $(1)/usr/include/apr-1 \
|
||||
$(1)/usr/lib/pkgconfig
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/apu-1-config $(1)/usr/bin
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/apr-1/* $(1)/usr/include/apr-1
|
||||
ifneq ($(CONFIG_PACKAGE_libaprutil-crypto-openssl)$(CONFIG_PACKAGE_libaprutil-dbd-pgsql)$(CONFIG_PACKAGE_libaprutil-dbd-sqlite3)$(CONFIG_PACKAGE_libaprutil-ldap),)
|
||||
$(INSTALL_DIR) $(1)/usr/lib/apr-util-1
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/apr-util-1/apr_*{la,a,so*} \
|
||||
$(1)/usr/lib/apr-util-1
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/apr-util-1/apr_*{la,a,so*} \
|
||||
$(1)/usr/lib/apr-util-1
|
||||
endif
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libaprutil-1.{la,a,so*} \
|
||||
$(1)/usr/lib/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/apr-util-1.pc \
|
||||
$(1)/usr/lib/pkgconfig/
|
||||
$(SED) 's, -e \"s -I$$$$prefix/lib g\",,g' $(1)/usr/bin/apu-1-config
|
||||
$(SED) 's,^libdir=\"$$$${exec_prefix}/lib,libdir=\"$(STAGING_DIR)/usr/lib,g' $(1)/usr/bin/apu-1-config
|
||||
$(SED) 's,^includedir=\"$$$${prefix}/include/,includedir=\"$(STAGING_DIR)/usr/include/,g' $(1)/usr/bin/apu-1-config
|
||||
$(SED) 's,-L$$$$libdir,,g' $(1)/usr/bin/apu-1-config
|
||||
$(SED) 's,-R$$$$libdir,,g' $(1)/usr/bin/apu-1-config
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libaprutil-1.{la,a,so*} \
|
||||
$(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/apr-util-1.pc \
|
||||
$(1)/usr/lib/pkgconfig
|
||||
$(SED) '/^prefix=\|^exec_prefix=/s|/usr|$(STAGING_DIR)/usr|' \
|
||||
$(1)/usr/bin/apu-1-config
|
||||
endef
|
||||
|
||||
define Package/libaprutil/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libaprutil-1.so.* $(1)/usr/lib/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libaprutil-1.so.* $(1)/usr/lib
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,libaprutil))
|
||||
|
|
|
@ -1,21 +0,0 @@
|
|||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -8,6 +8,7 @@ APRUTIL_MAJOR_VERSION=@APRUTIL_MAJOR_VER
|
||||
APRUTIL_DOTTED_VERSION=@APRUTIL_DOTTED_VERSION@
|
||||
|
||||
srcdir = @srcdir@
|
||||
+top_builddir = @top_builddir@
|
||||
VPATH = @srcdir@
|
||||
|
||||
INCLUDES = @APRUTIL_PRIV_INCLUDES@ @APR_INCLUDES@ @APRUTIL_INCLUDES@
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -41,6 +41,8 @@ AC_SUBST(APU_CONFIG_LOCATION)
|
||||
AC_CANONICAL_SYSTEM
|
||||
|
||||
AC_PROG_INSTALL
|
||||
+AC_PROG_LIBTOOL
|
||||
+LT_INIT
|
||||
|
||||
# Use -no-install or -no-fast-install to link the test
|
||||
# programs on all platforms but Darwin, where it would cause
|
Loading…
Reference in a new issue