luaposix: remove eglibc remnants
As a side-effect, this adds the getlogin function back when using glibc. Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
This commit is contained in:
parent
b83212e67e
commit
a5aa5e7cfb
2 changed files with 1 additions and 38 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=luaposix
|
||||
PKG_VERSION:=v33.2.1
|
||||
PKG_RELEASE:=5
|
||||
PKG_RELEASE:=6
|
||||
|
||||
PKG_SOURCE:=release-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://github.com/luaposix/luaposix/archive/
|
||||
|
@ -49,13 +49,6 @@ ifeq ($(CONFIG_USE_MUSL),y)
|
|||
TARGET_CFLAGS += -D_XOPEN_REALTIME=1
|
||||
endif
|
||||
|
||||
ifneq ($(CONFIG_USE_GLIBC),)
|
||||
ifeq ($(CONFIG_EGLIBC_OPTION_EGLIBC_UTMP),)
|
||||
TARGET_CFLAGS += -DNO_GETLOGIN
|
||||
endif
|
||||
endif
|
||||
|
||||
|
||||
define Package/luaposix/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib/lua/posix
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/ext/posix/.libs/posix.so $(1)/usr/lib/lua
|
||||
|
|
|
@ -1,30 +0,0 @@
|
|||
diff --git a/ext/posix/unistd.c b/ext/posix/unistd.c
|
||||
index 9276640..69c8cef 100644
|
||||
--- a/ext/posix/unistd.c
|
||||
+++ b/ext/posix/unistd.c
|
||||
@@ -525,6 +525,7 @@ Pgetgroups(lua_State *L)
|
||||
#endif
|
||||
|
||||
|
||||
+#ifndef NO_GETLOGIN
|
||||
/***
|
||||
Current logged-in user.
|
||||
@treturn[1] string username, if successful
|
||||
@@ -537,6 +538,7 @@ Pgetlogin(lua_State *L)
|
||||
checknargs(L, 0);
|
||||
return pushstringresult(getlogin());
|
||||
}
|
||||
+#endif
|
||||
|
||||
|
||||
/***
|
||||
@@ -1044,7 +1046,9 @@ static const luaL_Reg posix_unistd_fns[] =
|
||||
LPOSIX_FUNC( Pgetegid ),
|
||||
LPOSIX_FUNC( Pgeteuid ),
|
||||
LPOSIX_FUNC( Pgetgid ),
|
||||
+#ifndef NO_GETLOGIN
|
||||
LPOSIX_FUNC( Pgetlogin ),
|
||||
+#endif
|
||||
LPOSIX_FUNC( Pgetpgrp ),
|
||||
LPOSIX_FUNC( Pgetpid ),
|
||||
LPOSIX_FUNC( Pgetppid ),
|
Loading…
Reference in a new issue