gstreamer1: Disable debug + other fixes
Disabled a bunch of debug stuff in order to save size. Also removed the rpath stuff as that has not been needed for a long time. Added PKG_BUILD_PARALLEL for faster compilation. Removed two patches that have --disable configure parameters now. Refreshed patches. Size of libgstreamer1 from 822243 to 529366 on mvebu. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
c556ba0053
commit
a5a0a35081
5 changed files with 11 additions and 83 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=gstreamer1
|
||||
PKG_VERSION:=1.15.2
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org> \
|
||||
Ted Hess <thess@kitschensync.net>
|
||||
|
@ -25,6 +25,7 @@ PKG_HASH:=27a3211eb5c3f6929c5f123ffecaac0ea6e9ed6b93be879c033a7d5af13ad7e6
|
|||
PKG_FIXUP:=autoreconf
|
||||
PKG_REMOVE_FILES:=autogen.sh aclocal.m4
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
@ -118,13 +119,20 @@ GST_VERSION:=1.0
|
|||
|
||||
CONFIGURE_ARGS += \
|
||||
--enable-static \
|
||||
--disable-Bsymbolic \
|
||||
--disable-benchmarks \
|
||||
--disable-debug \
|
||||
--disable-examples \
|
||||
--disable-failing-tests \
|
||||
--disable-fatal-warnings \
|
||||
--disable-introspection \
|
||||
--disable-glib-asserts \
|
||||
--disable-gobject-cast-checks \
|
||||
--disable-gst-tracer-hooks \
|
||||
--disable-gst-debug \
|
||||
--disable-gtk-doc-html \
|
||||
--disable-option-parsing \
|
||||
--disable-rpath \
|
||||
--disable-tests \
|
||||
--disable-valgrind \
|
||||
--without-dw \
|
||||
|
@ -132,10 +140,6 @@ CONFIGURE_ARGS += \
|
|||
--without-libintl-prefix \
|
||||
--without-unwind
|
||||
|
||||
EXTRA_LDFLAGS+= \
|
||||
-Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
|
||||
$(if $(ICONV_FULL),-liconv)
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/include/gstreamer-$(GST_VERSION)
|
||||
( cd $(PKG_INSTALL_DIR); $(CP) \
|
||||
|
|
|
@ -18,7 +18,7 @@
|
|||
data
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -1086,7 +1086,6 @@ libs/gst/net/Makefile
|
||||
@@ -1108,7 +1108,6 @@ libs/gst/net/Makefile
|
||||
plugins/Makefile
|
||||
plugins/elements/Makefile
|
||||
plugins/tracers/Makefile
|
||||
|
|
|
@ -1,43 +0,0 @@
|
|||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -7,7 +7,7 @@ aclocaldir = $(datadir)/aclocal
|
||||
aclocal_DATA = gst-element-check-1.0.m4
|
||||
|
||||
SUBDIRS = pkgconfig \
|
||||
- gst libs plugins tests \
|
||||
+ gst libs plugins \
|
||||
docs \
|
||||
m4 \
|
||||
common \
|
||||
@@ -19,7 +19,7 @@ endif
|
||||
|
||||
# These are all the possible subdirs
|
||||
DIST_SUBDIRS = pkgconfig \
|
||||
- gst libs plugins tools tests \
|
||||
+ gst libs plugins tools \
|
||||
docs \
|
||||
m4 \
|
||||
common \
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -1086,20 +1086,6 @@ libs/gst/net/Makefile
|
||||
plugins/Makefile
|
||||
plugins/elements/Makefile
|
||||
plugins/tracers/Makefile
|
||||
-tests/Makefile
|
||||
-tests/benchmarks/Makefile
|
||||
-tests/check/Makefile
|
||||
-tests/misc/Makefile
|
||||
-tests/examples/Makefile
|
||||
-tests/examples/adapter/Makefile
|
||||
-tests/examples/controller/Makefile
|
||||
-tests/examples/stepping/Makefile
|
||||
-tests/examples/helloworld/Makefile
|
||||
-tests/examples/memory/Makefile
|
||||
-tests/examples/netclock/Makefile
|
||||
-tests/examples/ptp/Makefile
|
||||
-tests/examples/streamiddemux/Makefile
|
||||
-tests/examples/streams/Makefile
|
||||
tools/Makefile
|
||||
common/Makefile
|
||||
common/m4/Makefile
|
|
@ -1,33 +0,0 @@
|
|||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -8,7 +8,6 @@ aclocal_DATA = gst-element-check-1.0.m4
|
||||
|
||||
SUBDIRS = pkgconfig \
|
||||
gst libs plugins \
|
||||
- docs \
|
||||
m4 \
|
||||
common \
|
||||
data
|
||||
@@ -20,7 +19,6 @@ endif
|
||||
# These are all the possible subdirs
|
||||
DIST_SUBDIRS = pkgconfig \
|
||||
gst libs plugins tools \
|
||||
- docs \
|
||||
m4 \
|
||||
common \
|
||||
data
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -1089,12 +1089,6 @@ plugins/tracers/Makefile
|
||||
tools/Makefile
|
||||
common/Makefile
|
||||
common/m4/Makefile
|
||||
-docs/Makefile
|
||||
-docs/gst/Makefile
|
||||
-docs/gst/gstreamer.types
|
||||
-docs/libs/Makefile
|
||||
-docs/plugins/Makefile
|
||||
-docs/version.entities
|
||||
m4/Makefile
|
||||
pkgconfig/Makefile
|
||||
stamp.h
|
|
@ -1,6 +1,6 @@
|
|||
--- a/gst/gstplugin.c
|
||||
+++ b/gst/gstplugin.c
|
||||
@@ -776,15 +776,8 @@ _priv_gst_plugin_load_file_for_registry (const gchar * filename,
|
||||
@@ -777,15 +777,8 @@ _priv_gst_plugin_load_file_for_registry (const gchar * filename,
|
||||
goto return_error;
|
||||
}
|
||||
|
||||
|
|
Loading…
Reference in a new issue