qemu: update to 8.1.2
Changes: - Update to 8.1.2 - Refresh patches - Replace absent option --with-git-submodules with --disable-download Fix #22530 Signed-off-by: Vladimir Ermakov <vooon341@gmail.com>
This commit is contained in:
parent
7a393aea9f
commit
a517b7660b
4 changed files with 9 additions and 9 deletions
|
@ -9,10 +9,10 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=qemu
|
||||
PKG_VERSION:=8.0.2
|
||||
PKG_VERSION:=8.1.2
|
||||
PKG_RELEASE:=1
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_HASH:=f060abd435fbe6794125e2c398568ffc3cfa540042596907a8b18edca34cf6a5
|
||||
PKG_HASH:=541526a764576eb494d2ff5ec46aeb253e62ea29035d1c23c0a8af4e6cd4f087
|
||||
PKG_SOURCE_URL:=http://download.qemu.org/
|
||||
PKG_LICENSE:=GPL-2.0-only
|
||||
PKG_LICENSE_FILES:=LICENSE tcg/LICENSE
|
||||
|
@ -392,7 +392,7 @@ CONFIGURE_ARGS += \
|
|||
--disable-docs \
|
||||
--disable-fuse \
|
||||
--disable-gcrypt \
|
||||
--with-git-submodules=ignore \
|
||||
--disable-download \
|
||||
--disable-glusterfs \
|
||||
--disable-gnutls \
|
||||
--disable-guest-agent-msi \
|
||||
|
|
|
@ -11,9 +11,9 @@ OpenWrt base build system decide flavor of fortify_source to use
|
|||
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -896,6 +896,8 @@ for opt do
|
||||
@@ -823,6 +823,8 @@ for opt do
|
||||
;;
|
||||
--disable-vfio-user-server) vfio_user_server="disabled"
|
||||
--gdb=*) gdb_bin="$optarg"
|
||||
;;
|
||||
+ --disable-fortify-source) fortify_source="no"
|
||||
+ ;;
|
||||
|
|
|
@ -32,9 +32,9 @@ Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
|
|||
#endif /* CONFIG_LINUX */
|
||||
|
||||
#include "qemu/osdep.h"
|
||||
@@ -29,6 +26,13 @@
|
||||
#include <sys/vfs.h>
|
||||
@@ -57,6 +54,13 @@ QemuFsType qemu_fd_getfs(int fd)
|
||||
#endif
|
||||
}
|
||||
|
||||
+#ifndef MAP_SYNC
|
||||
+#define MAP_SYNC 0x0
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -3192,10 +3192,6 @@ subdir('common-user')
|
||||
@@ -3451,10 +3451,6 @@ subdir('common-user')
|
||||
subdir('bsd-user')
|
||||
subdir('linux-user')
|
||||
|
||||
|
@ -11,7 +11,7 @@
|
|||
# accel modules
|
||||
tcg_real_module_ss = ss.source_set()
|
||||
tcg_real_module_ss.add_all(when: 'CONFIG_TCG_MODULAR', if_true: tcg_module_ss)
|
||||
@@ -3687,10 +3683,6 @@ subdir('scripts')
|
||||
@@ -3945,10 +3941,6 @@ subdir('scripts')
|
||||
subdir('tools')
|
||||
subdir('pc-bios')
|
||||
subdir('docs')
|
||||
|
|
Loading…
Reference in a new issue