libxml2: patch security issues
Fixes CVE-2019-19956 CVE-2020-24977 CVE-2019-20388 CVE-2020-7595 Signed-off-by: Jan Pavlinec <jan.pavlinec@nic.cz>
This commit is contained in:
parent
f99f60d7b7
commit
a4cbd04df9
5 changed files with 135 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=libxml2
|
PKG_NAME:=libxml2
|
||||||
PKG_VERSION:=2.9.9
|
PKG_VERSION:=2.9.9
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=3
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://xmlsoft.org/sources/
|
PKG_SOURCE_URL:=http://xmlsoft.org/sources/
|
||||||
|
|
33
libs/libxml2/patches/CVE-2019-19956.patch
Normal file
33
libs/libxml2/patches/CVE-2019-19956.patch
Normal file
|
@ -0,0 +1,33 @@
|
||||||
|
From 5a02583c7e683896d84878bd90641d8d9b0d0549 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Zhipeng Xie <xiezhipeng1@huawei.com>
|
||||||
|
Date: Wed, 7 Aug 2019 17:39:17 +0800
|
||||||
|
Subject: [PATCH] Fix memory leak in xmlParseBalancedChunkMemoryRecover
|
||||||
|
|
||||||
|
When doc is NULL, namespace created in xmlTreeEnsureXMLDecl
|
||||||
|
is bind to newDoc->oldNs, in this case, set newDoc->oldNs to
|
||||||
|
NULL and free newDoc will cause a memory leak.
|
||||||
|
|
||||||
|
Found with libFuzzer.
|
||||||
|
|
||||||
|
Closes #82.
|
||||||
|
---
|
||||||
|
parser.c | 3 ++-
|
||||||
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/parser.c b/parser.c
|
||||||
|
index 1ce1ccf14..26d9f4e3b 100644
|
||||||
|
--- a/parser.c
|
||||||
|
+++ b/parser.c
|
||||||
|
@@ -13894,7 +13894,8 @@ xmlParseBalancedChunkMemoryRecover(xmlDocPtr doc, xmlSAXHandlerPtr sax,
|
||||||
|
xmlFreeParserCtxt(ctxt);
|
||||||
|
newDoc->intSubset = NULL;
|
||||||
|
newDoc->extSubset = NULL;
|
||||||
|
- newDoc->oldNs = NULL;
|
||||||
|
+ if(doc != NULL)
|
||||||
|
+ newDoc->oldNs = NULL;
|
||||||
|
xmlFreeDoc(newDoc);
|
||||||
|
|
||||||
|
return(ret);
|
||||||
|
--
|
||||||
|
GitLab
|
||||||
|
|
33
libs/libxml2/patches/CVE-2019-20388.patch
Normal file
33
libs/libxml2/patches/CVE-2019-20388.patch
Normal file
|
@ -0,0 +1,33 @@
|
||||||
|
From 6088a74bcf7d0c42e24cff4594d804e1d3c9fbca Mon Sep 17 00:00:00 2001
|
||||||
|
From: Zhipeng Xie <xiezhipeng1@huawei.com>
|
||||||
|
Date: Tue, 20 Aug 2019 16:33:06 +0800
|
||||||
|
Subject: [PATCH] Fix memory leak in xmlSchemaValidateStream
|
||||||
|
|
||||||
|
When ctxt->schema is NULL, xmlSchemaSAXPlug->xmlSchemaPreRun
|
||||||
|
alloc a new schema for ctxt->schema and set vctxt->xsiAssemble
|
||||||
|
to 1. Then xmlSchemaVStart->xmlSchemaPreRun initialize
|
||||||
|
vctxt->xsiAssemble to 0 again which cause the alloced schema
|
||||||
|
can not be freed anymore.
|
||||||
|
|
||||||
|
Found with libFuzzer.
|
||||||
|
|
||||||
|
Signed-off-by: Zhipeng Xie <xiezhipeng1@huawei.com>
|
||||||
|
---
|
||||||
|
xmlschemas.c | 1 -
|
||||||
|
1 file changed, 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/xmlschemas.c b/xmlschemas.c
|
||||||
|
index 301c84499..39d92182f 100644
|
||||||
|
--- a/xmlschemas.c
|
||||||
|
+++ b/xmlschemas.c
|
||||||
|
@@ -28090,7 +28090,6 @@ xmlSchemaPreRun(xmlSchemaValidCtxtPtr vctxt) {
|
||||||
|
vctxt->nberrors = 0;
|
||||||
|
vctxt->depth = -1;
|
||||||
|
vctxt->skipDepth = -1;
|
||||||
|
- vctxt->xsiAssemble = 0;
|
||||||
|
vctxt->hasKeyrefs = 0;
|
||||||
|
#ifdef ENABLE_IDC_NODE_TABLES_TEST
|
||||||
|
vctxt->createIDCNodeTables = 1;
|
||||||
|
--
|
||||||
|
GitLab
|
||||||
|
|
36
libs/libxml2/patches/CVE-2020-24977.patch
Normal file
36
libs/libxml2/patches/CVE-2020-24977.patch
Normal file
|
@ -0,0 +1,36 @@
|
||||||
|
From 50f06b3efb638efb0abd95dc62dca05ae67882c2 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Nick Wellnhofer <wellnhofer@aevum.de>
|
||||||
|
Date: Fri, 7 Aug 2020 21:54:27 +0200
|
||||||
|
Subject: [PATCH] Fix out-of-bounds read with 'xmllint --htmlout'
|
||||||
|
|
||||||
|
Make sure that truncated UTF-8 sequences don't cause an out-of-bounds
|
||||||
|
array access.
|
||||||
|
|
||||||
|
Thanks to @SuhwanSong and the Agency for Defense Development (ADD) for
|
||||||
|
the report.
|
||||||
|
|
||||||
|
Fixes #178.
|
||||||
|
---
|
||||||
|
xmllint.c | 6 ++++++
|
||||||
|
1 file changed, 6 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/xmllint.c b/xmllint.c
|
||||||
|
index f6a8e4636..c647486f3 100644
|
||||||
|
--- a/xmllint.c
|
||||||
|
+++ b/xmllint.c
|
||||||
|
@@ -528,6 +528,12 @@ static void
|
||||||
|
xmlHTMLEncodeSend(void) {
|
||||||
|
char *result;
|
||||||
|
|
||||||
|
+ /*
|
||||||
|
+ * xmlEncodeEntitiesReentrant assumes valid UTF-8, but the buffer might
|
||||||
|
+ * end with a truncated UTF-8 sequence. This is a hack to at least avoid
|
||||||
|
+ * an out-of-bounds read.
|
||||||
|
+ */
|
||||||
|
+ memset(&buffer[sizeof(buffer)-4], 0, 4);
|
||||||
|
result = (char *) xmlEncodeEntitiesReentrant(NULL, BAD_CAST buffer);
|
||||||
|
if (result) {
|
||||||
|
xmlGenericError(xmlGenericErrorContext, "%s", result);
|
||||||
|
--
|
||||||
|
GitLab
|
||||||
|
|
32
libs/libxml2/patches/CVE-2020-7595.patch
Normal file
32
libs/libxml2/patches/CVE-2020-7595.patch
Normal file
|
@ -0,0 +1,32 @@
|
||||||
|
From 0e1a49c8907645d2e155f0d89d4d9895ac5112b5 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Zhipeng Xie <xiezhipeng1@huawei.com>
|
||||||
|
Date: Thu, 12 Dec 2019 17:30:55 +0800
|
||||||
|
Subject: [PATCH] Fix infinite loop in xmlStringLenDecodeEntities
|
||||||
|
|
||||||
|
When ctxt->instate == XML_PARSER_EOF,xmlParseStringEntityRef
|
||||||
|
return NULL which cause a infinite loop in xmlStringLenDecodeEntities
|
||||||
|
|
||||||
|
Found with libFuzzer.
|
||||||
|
|
||||||
|
Signed-off-by: Zhipeng Xie <xiezhipeng1@huawei.com>
|
||||||
|
---
|
||||||
|
parser.c | 3 ++-
|
||||||
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/parser.c b/parser.c
|
||||||
|
index d1c319631..a34bb6cdd 100644
|
||||||
|
--- a/parser.c
|
||||||
|
+++ b/parser.c
|
||||||
|
@@ -2646,7 +2646,8 @@ xmlStringLenDecodeEntities(xmlParserCtxtPtr ctxt, const xmlChar *str, int len,
|
||||||
|
else
|
||||||
|
c = 0;
|
||||||
|
while ((c != 0) && (c != end) && /* non input consuming loop */
|
||||||
|
- (c != end2) && (c != end3)) {
|
||||||
|
+ (c != end2) && (c != end3) &&
|
||||||
|
+ (ctxt->instate != XML_PARSER_EOF)) {
|
||||||
|
|
||||||
|
if (c == 0) break;
|
||||||
|
if ((c == '&') && (str[1] == '#')) {
|
||||||
|
--
|
||||||
|
GitLab
|
||||||
|
|
Loading…
Reference in a new issue