sslh: update to 1.20
Fixed maintainer entry.
Added patch fixing compilation.
Signed-off-by: Rosen Penev <rosenp@gmail.com>
(cherry picked from commit ded3ad41b8
)
This commit is contained in:
parent
23251b93a9
commit
a41e068db8
2 changed files with 16 additions and 4 deletions
|
@ -8,12 +8,14 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=sslh
|
||||
PKG_VERSION:=v1.19c
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=v1.20
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://rutschle.net/tech/sslh/
|
||||
PKG_HASH:=bb11dfa88b27ae1ec825a1b8156000c3f17f7e8f042311f19b7a249193c47bf3
|
||||
PKG_HASH:=a7f49b0a1cfcb7bb9d97f5ffa932bff11c5f65d9a9bd8fe1812481dee5855116
|
||||
|
||||
PKG_MAINTAINER:=Jonathan McCrohan <jmccrohan@gmail.com>
|
||||
PKG_LICENSE:=GPL-2.0-or-later
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
||||
|
@ -26,7 +28,6 @@ define Package/sslh
|
|||
TITLE:=SSL/SSH multiplexer
|
||||
DEPENDS:=+libconfig +USE_UCLIBC:libpcre +USE_MUSL:libpcre
|
||||
URL:=https://rutschle.net/tech/sslh/README.html
|
||||
PKG_MAINTAINER:=Jonathan McCrohan <jmccrohan@gmail.com>
|
||||
endef
|
||||
|
||||
define Package/sslh/conffiles
|
||||
|
|
11
net/sslh/patches/010-format.patch
Normal file
11
net/sslh/patches/010-format.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- a/sslh-main.c
|
||||
+++ b/sslh-main.c
|
||||
@@ -167,7 +167,7 @@ void cmd_ssl_to_tls(int argc, char* argv[])
|
||||
strcpy(argv[i], "--tls");
|
||||
/* foreground option not parsed yet, syslog not open, just print on
|
||||
* stderr and hope for the best */
|
||||
- fprintf(stderr, ssl_err_msg);
|
||||
+ fprintf(stderr, "%s", ssl_err_msg);
|
||||
}
|
||||
}
|
||||
}
|
Loading…
Reference in a new issue