python3-libselinux: Update to 3.5, rename source/target package
* Rename: * Source package from python3-libselinux to python-selinux * Target package from python3-libselinux to python3-selinux * Update dependents with new target package name * Remove patches: * 010-setup-py-custom-cc.patch: LDSHARED is already set as part of $(PYTHON3_VARS) * 020-Make-use-of-variables-when-defining-libdir-and-inclu.patch: This package doesn't install the libselinux.pc file * Update package title and dependencies * Remove Build/InstallDev (files not used by any other package) * Use Py3Package to build Python bytecode and source packages Signed-off-by: Jeffery To <jeffery.to@gmail.com>
This commit is contained in:
parent
6938f58a45
commit
a205483547
4 changed files with 28 additions and 67 deletions
|
@ -5,38 +5,38 @@
|
|||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
SRC_NAME:=libselinux
|
||||
PKG_NAME:=python3-$(SRC_NAME)
|
||||
PKG_VERSION:=3.3
|
||||
PKG_RELEASE:=3
|
||||
PKG_NAME:=python-selinux
|
||||
PKG_VERSION:=3.5
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/python-libselinux/$(SRC_NAME)-$(PKG_VERSION)
|
||||
SRC_NAME:=libselinux
|
||||
PKG_SOURCE:=$(SRC_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://github.com/SELinuxProject/selinux/releases/download/$(PKG_VERSION)
|
||||
PKG_HASH:=acfdee27633d2496508c28727c3d41d3748076f66d42fccde2e6b9f3463a7057
|
||||
PKG_BUILD_DEPENDS:=swig/host
|
||||
PKG_HASH:=9a3a3705ac13a2ccca2de6d652b6356fead10f36fb33115c185c5ccdf29eec19
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)/$(SRC_NAME)-$(PKG_VERSION)
|
||||
|
||||
PKG_MAINTAINER:=Thomas Petazzoni <thomas.petazzoni@bootlin.com>
|
||||
PKG_LICENSE:=libselinux-1.0
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
PKG_CPE_ID:=cpe:/a:selinuxproject:libselinux
|
||||
|
||||
PKG_BUILD_DEPENDS:=swig/host
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PYTHON3_PKG_BUILD:=0
|
||||
PKG_INSTALL:=1
|
||||
MAKE_PATH:=src
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include ../python3-package.mk
|
||||
|
||||
define Package/python3-libselinux
|
||||
TITLE:=Python bindings for the runtime SELinux library
|
||||
define Package/python3-selinux
|
||||
SUBMENU:=Python
|
||||
SECTION:=lang
|
||||
CATEGORY:=Languages
|
||||
DEPENDS:=+libpcre +musl-fts +python3 +libselinux
|
||||
TITLE:=SELinux runtime library bindings
|
||||
DEPENDS:=+python3-light +libselinux
|
||||
URL:=http://selinuxproject.org/page/Main_Page
|
||||
endef
|
||||
|
||||
define Package/python3-libselinux/description
|
||||
define Package/python3-selinux/description
|
||||
libselinux is the runtime SELinux library that provides
|
||||
interfaces (e.g. library functions for the SELinux kernel
|
||||
APIs like getcon(), other support functions like
|
||||
|
@ -48,34 +48,27 @@ define Package/python3-libselinux/description
|
|||
This package provides the Python bindings for libselinux.
|
||||
endef
|
||||
|
||||
MAKE_VARS += \
|
||||
$(PYTHON3_VARS) \
|
||||
$(HOST_PYTHON3_PIP_VARS) \
|
||||
PYTHON_SETUP_ARGS=--no-compile
|
||||
|
||||
MAKE_FLAGS += \
|
||||
SHLIBDIR=/usr/lib
|
||||
|
||||
ifneq ($(CONFIG_USE_MUSL),)
|
||||
MAKE_FLAGS += FTS_LDLIBS=-lfts
|
||||
TARGET_CFLAGS += -D_LARGEFILE64_SOURCE
|
||||
endif
|
||||
|
||||
MAKE_FLAGS += \
|
||||
FTS_LDLIBS=-lfts \
|
||||
SHLIBDIR=/usr/lib \
|
||||
PYTHON=$(PYTHON3) \
|
||||
PYINC="-I $(PYTHON3_INC_DIR)" \
|
||||
PYLIBS="-lpython$(PYTHON3_VERSION)" \
|
||||
$(PYTHON3_VARS)
|
||||
|
||||
define Build/Compile
|
||||
$(call Build/Compile/Default,swigify pywrap)
|
||||
$(call Build/Compile/Default,pywrap)
|
||||
endef
|
||||
|
||||
define Build/Install
|
||||
$(call Build/Install/Default,install-pywrap)
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)$(PYTHON3_PKG_DIR)
|
||||
$(CP) $(PKG_INSTALL_DIR)$(PYTHON3_PKG_DIR)/* $(1)$(PYTHON3_PKG_DIR)
|
||||
endef
|
||||
|
||||
define Package/python3-libselinux/install
|
||||
$(INSTALL_DIR) $(1)$(PYTHON3_PKG_DIR)
|
||||
$(CP) $(PKG_INSTALL_DIR)$(PYTHON3_PKG_DIR)/* $(1)$(PYTHON3_PKG_DIR)
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,python3-libselinux))
|
||||
$(eval $(call Py3Package,python3-selinux))
|
||||
$(eval $(call BuildPackage,python3-selinux))
|
||||
$(eval $(call BuildPackage,python3-selinux-src))
|
|
@ -1,11 +0,0 @@
|
|||
--- a/src/Makefile
|
||||
+++ b/src/Makefile
|
||||
@@ -139,7 +139,7 @@ SWIGRUBY = swig -Wall -ruby -o $(SWIGRUB
|
||||
all: $(LIBA) $(LIBSO) $(LIBPC)
|
||||
|
||||
pywrap: all selinuxswig_python_exception.i
|
||||
- CFLAGS="$(CFLAGS) $(SWIG_CFLAGS)" $(PYTHON) setup.py build_ext
|
||||
+ LDSHARED="$(CC) -shared" CFLAGS="$(CFLAGS) $(SWIG_CFLAGS)" $(PYTHON) setup.py build_ext
|
||||
|
||||
rubywrap: all $(SWIGRUBYSO)
|
||||
|
|
@ -1,21 +0,0 @@
|
|||
Pkg-config definitions commonly make use of ${exec_prefix} and ${prefix}
|
||||
when defining libdir and includedir, respectively. OpenWrt, for example,
|
||||
relies on this when it adjusts things for cross compiling.
|
||||
|
||||
Signed-off-by: W. Michael Petullo <mike@flyn.org>
|
||||
---
|
||||
src/libselinux.pc.in | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
--- a/src/libselinux.pc.in
|
||||
+++ b/src/libselinux.pc.in
|
||||
@@ -1,7 +1,7 @@
|
||||
prefix=@prefix@
|
||||
exec_prefix=${prefix}
|
||||
-libdir=@libdir@
|
||||
-includedir=@includedir@
|
||||
+libdir=${exec_prefix}/lib
|
||||
+includedir=${prefix}/include
|
||||
|
||||
Name: libselinux
|
||||
Description: SELinux utility library
|
|
@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=selinux-python
|
||||
PKG_VERSION:=3.2
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://github.com/SELinuxProject/selinux/releases/download/$(PKG_VERSION)
|
||||
|
@ -28,7 +28,7 @@ include ../../lang/python/python3-package.mk
|
|||
|
||||
define Package/selinux-python/Default
|
||||
SECTION:=utils
|
||||
DEPENDS:=+python3 +python3-libselinux
|
||||
DEPENDS:=+python3 +python3-selinux
|
||||
CATEGORY:=Utilities
|
||||
URL:=http://selinuxproject.org/page/Main_Page
|
||||
endef
|
||||
|
|
Loading…
Reference in a new issue