python-exceptiongroup: add package for 1.0.4
Signed-off-by: Julien Malik <julien.malik@paraiso.me>
This commit is contained in:
parent
69655222fc
commit
a19f331b06
2 changed files with 73 additions and 0 deletions
42
lang/python/python-exceptiongroup/Makefile
Normal file
42
lang/python/python-exceptiongroup/Makefile
Normal file
|
@ -0,0 +1,42 @@
|
|||
#
|
||||
# Copyright (C) 2022 Julien Malik <julien.malik@paraiso.me>
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=python-exceptiongroup
|
||||
PKG_VERSION:=1.0.4
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PYPI_NAME:=exceptiongroup
|
||||
PKG_HASH:=bd14967b79cd9bdb54d97323216f8fdf533e278df937aa2a90089e7d6e06e5ec
|
||||
|
||||
PKG_LICENSE:=MIT,Python-2.0
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
PKG_MAINTAINER:=Julien Malik <julien.malik@paraiso.me>
|
||||
|
||||
include ../pypi.mk
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include ../python3-package.mk
|
||||
|
||||
define Package/python3-exceptiongroup
|
||||
SECTION:=lang
|
||||
CATEGORY:=Languages
|
||||
SUBMENU:=Python
|
||||
TITLE:=Backport of PEP 654 (exception groups)
|
||||
URL:=https://github.com/agronholm/exceptiongroup
|
||||
DEPENDS:= \
|
||||
+python3-light \
|
||||
+python3-attrs
|
||||
endef
|
||||
|
||||
define Package/python3-exceptiongroup/description
|
||||
This is a backport of the BaseExceptionGroup and ExceptionGroup classes from Python 3.11.
|
||||
endef
|
||||
|
||||
$(eval $(call Py3Package,python3-exceptiongroup))
|
||||
$(eval $(call BuildPackage,python3-exceptiongroup))
|
||||
$(eval $(call BuildPackage,python3-exceptiongroup-src))
|
|
@ -0,0 +1,31 @@
|
|||
From 99e590f2177148420f3556bbb0dc2e493e94e45f Mon Sep 17 00:00:00 2001
|
||||
From: Julien Malik <julien.malik@paraiso.me>
|
||||
Date: Sat, 26 Nov 2022 13:05:20 +0100
|
||||
Subject: [PATCH] add setup.py to avoid depending on flit for building
|
||||
|
||||
---
|
||||
setup.py | 18 ++++++++++++++++++
|
||||
1 file changed, 18 insertions(+)
|
||||
create mode 100644 setup.py
|
||||
|
||||
--- /dev/null
|
||||
+++ b/setup.py
|
||||
@@ -0,0 +1,18 @@
|
||||
+#!/usr/bin/env python
|
||||
+
|
||||
+import setuptools
|
||||
+
|
||||
+setuptools.setup(
|
||||
+ name='exceptiongroup',
|
||||
+ version='1.0.4',
|
||||
+ description='Backport of PEP 654 (exception groups)',
|
||||
+ author='Alex Grönholm',
|
||||
+ author_email='Alex Grönholm <alex.gronholm@nextday.fi>',
|
||||
+ url='https://github.com/agronholm/exceptiongroup',
|
||||
+ packages=['exceptiongroup'],
|
||||
+ package_data={'': ['*']},
|
||||
+ package_dir={'': 'src'},
|
||||
+ extras_require={'test': ['pytest >= 6']},
|
||||
+ python_requires='>=3.7',
|
||||
+)
|
||||
+
|
Loading…
Reference in a new issue