mjpg-streamer: Fix SIGTRAP in v4l2uvc
Signed-off-by: Ted Hess <thess@kitschensync.net>
This commit is contained in:
parent
0421b32131
commit
a17fa8c058
2 changed files with 12 additions and 1 deletions
|
@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
|
|||
PKG_NAME:=mjpg-streamer
|
||||
PKG_REV:=182
|
||||
PKG_VERSION:=r$(PKG_REV)
|
||||
PKG_RELEASE:=7
|
||||
PKG_RELEASE:=8
|
||||
PKG_MAINTAINER:=Roger D <rogerdammit@gmail.com>
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).1.tar.bz2
|
||||
|
|
|
@ -0,0 +1,11 @@
|
|||
--- a/plugins/input_uvc/v4l2uvc.c
|
||||
+++ b/plugins/input_uvc/v4l2uvc.c
|
||||
@@ -130,7 +130,7 @@ int init_videoIn(struct vdIn *vd, char *
|
||||
return -1;
|
||||
}
|
||||
|
||||
- memcpy(&pglobal->in[id].in_formats[pglobal->in[id].formatCount], &fmtdesc, sizeof(input_format));
|
||||
+ memcpy(&pglobal->in[id].in_formats[pglobal->in[id].formatCount], &fmtdesc, sizeof(struct v4l2_fmtdesc));
|
||||
|
||||
if(fmtdesc.pixelformat == format)
|
||||
pglobal->in[id].currentFormat = pglobal->in[id].formatCount;
|
Loading…
Reference in a new issue