shadow: fix su controlling terminal #1521
Signed-off-by: Pelle Johnsen <pelle.johnsen@gmail.com>
This commit is contained in:
parent
5b8d596ab9
commit
a14b3c8651
2 changed files with 18 additions and 2 deletions
|
@ -1,5 +1,5 @@
|
||||||
#
|
#
|
||||||
# Copyright (C) 2008-2014 OpenWrt.org
|
# Copyright (C) 2008-2015 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=shadow
|
PKG_NAME:=shadow
|
||||||
PKG_VERSION:=4.2.1
|
PKG_VERSION:=4.2.1
|
||||||
PKG_RELEASE:=4
|
PKG_RELEASE:=5
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=http://pkg-shadow.alioth.debian.org/releases
|
PKG_SOURCE_URL:=http://pkg-shadow.alioth.debian.org/releases
|
||||||
|
|
16
utils/shadow/patches/004-fix-su-controoling-term.patch
Normal file
16
utils/shadow/patches/004-fix-su-controoling-term.patch
Normal file
|
@ -0,0 +1,16 @@
|
||||||
|
--- a/src/su.c
|
||||||
|
+++ b/src/su.c
|
||||||
|
@@ -1090,8 +1090,12 @@
|
||||||
|
|
||||||
|
if (fd >= 0) {
|
||||||
|
err = ioctl (fd, TIOCNOTTY, (char *) 0);
|
||||||
|
+ if (-1 == err && ENOTTY == errno) {
|
||||||
|
+ /* There are no controlling terminal already */
|
||||||
|
+ err = 0;
|
||||||
|
+ }
|
||||||
|
(void) close (fd);
|
||||||
|
- } else if (ENXIO == errno) {
|
||||||
|
+ } else if (ENXIO == errno || EACCES == errno) {
|
||||||
|
/* There are no controlling terminal already */
|
||||||
|
err = 0;
|
||||||
|
}
|
Loading…
Reference in a new issue