commit
a1057cea1f
5 changed files with 49 additions and 97 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=libgd
|
PKG_NAME:=libgd
|
||||||
PKG_VERSION:=2.2.5
|
PKG_VERSION:=2.2.5
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=3
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=https://github.com/$(PKG_NAME)/$(PKG_NAME)/releases/download/gd-$(PKG_VERSION)/
|
PKG_SOURCE_URL:=https://github.com/$(PKG_NAME)/$(PKG_NAME)/releases/download/gd-$(PKG_VERSION)/
|
||||||
|
@ -19,16 +19,16 @@ PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
|
||||||
PKG_LICENSE:=MIT
|
PKG_LICENSE:=MIT
|
||||||
PKG_LICENSE_FILES:=COPYING
|
PKG_LICENSE_FILES:=COPYING
|
||||||
|
|
||||||
PKG_FIXUP:=autoreconf
|
CMAKE_INSTALL:=1
|
||||||
PKG_INSTALL:=1
|
|
||||||
PKG_BUILD_PARALLEL:=1
|
PKG_BUILD_PARALLEL:=1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
include $(INCLUDE_DIR)/cmake.mk
|
||||||
|
|
||||||
define Package/libgd
|
define Package/libgd
|
||||||
SECTION:=libs
|
SECTION:=libs
|
||||||
CATEGORY:=Libraries
|
CATEGORY:=Libraries
|
||||||
DEPENDS:=+libjpeg +libpng +LIBGD_TIFF:libtiff +LIBGD_FREETYPE:libfreetype
|
DEPENDS:=+libjpeg +libpng +libwebp +LIBGD_TIFF:libtiff +LIBGD_FREETYPE:libfreetype
|
||||||
TITLE:=The GD graphics library
|
TITLE:=The GD graphics library
|
||||||
URL:=https://libgd.github.io/
|
URL:=https://libgd.github.io/
|
||||||
MENU:=1
|
MENU:=1
|
||||||
|
@ -56,58 +56,37 @@ define Package/libgd/config
|
||||||
endif
|
endif
|
||||||
endef
|
endef
|
||||||
|
|
||||||
TARGET_CFLAGS += $(FPIC)
|
TARGET_CFLAGS += $(FPIC) -ffunction-sections -fdata-sections -flto
|
||||||
|
|
||||||
CONFIGURE_ARGS += \
|
CMAKE_OPTIONS += \
|
||||||
--enable-shared \
|
-DENABLE_FONTCONFIG=OFF \
|
||||||
--enable-static \
|
-DENABLE_ICONV=OFF \
|
||||||
--disable-rpath \
|
-DENABLE_JPEG=ON \
|
||||||
--without-x \
|
-DENABLE_LIQ=OFF \
|
||||||
--without-fontconfig \
|
-DENABLE_PNG=ON \
|
||||||
--with-jpeg=$(STAGING_DIR)/usr \
|
-DENABLE_WEBP=ON \
|
||||||
--with-png=$(STAGING_DIR)/usr \
|
-DENABLE_XPM=OFF \
|
||||||
--without-xpm
|
-DZLIB_INCLUDE_DIR="$(STAGING_DIR)/usr"
|
||||||
|
|
||||||
ifdef CONFIG_LIBGD_TIFF
|
ifdef CONFIG_LIBGD_TIFF
|
||||||
CONFIGURE_ARGS+= \
|
CMAKE_OPTIONS += \
|
||||||
--with-tiff=$(STAGING_DIR)/usr
|
-DENABLE_TIFF=ON
|
||||||
else
|
else
|
||||||
CONFIGURE_ARGS+= \
|
CMAKE_OPTIONS += \
|
||||||
--without-tiff
|
-DENABLE_TIFF=OFF
|
||||||
endif
|
endif
|
||||||
|
|
||||||
ifdef CONFIG_LIBGD_FREETYPE
|
ifdef CONFIG_LIBGD_FREETYPE
|
||||||
CONFIGURE_ARGS+= \
|
CMAKE_OPTIONS += \
|
||||||
--with-freetype=$(STAGING_DIR)/usr
|
-DENABLE_FREETYPE=ON
|
||||||
else
|
else
|
||||||
CONFIGURE_ARGS+= \
|
CMAKE_OPTIONS += \
|
||||||
--without-freetype
|
-DENABLE_FREETYPE=OFF
|
||||||
endif
|
endif
|
||||||
|
|
||||||
CONFIGURE_VARS += \
|
|
||||||
ac_cv_header_iconv_h=no \
|
|
||||||
am_cv_func_iconv_works=no \
|
|
||||||
am_func_iconv=no
|
|
||||||
|
|
||||||
define Build/InstallDev
|
|
||||||
$(INSTALL_DIR) $(1)/usr/bin
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/gdlib-config $(1)/usr/bin/
|
|
||||||
$(SED) \
|
|
||||||
's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
|
|
||||||
$(1)/usr/bin/gdlib-config
|
|
||||||
$(INSTALL_DIR) $(1)/usr/include
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/entities.h $(1)/usr/include/
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/gd{,_color_map,_errors,_io,cache,fontg,fontl,fontmb,fonts,fontt,fx,pp}.h \
|
|
||||||
$(1)/usr/include/
|
|
||||||
$(INSTALL_DIR) $(1)/usr/lib
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libgd.{a,la,so*} $(1)/usr/lib/
|
|
||||||
$(INSTALL_DIR) $(2)/bin
|
|
||||||
$(LN) ../../usr/bin/gdlib-config $(2)/bin/
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/libgd/install
|
define Package/libgd/install
|
||||||
$(INSTALL_DIR) $(1)/usr/lib
|
$(INSTALL_DIR) $(1)/usr/lib
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libgd.so.* $(1)/usr/lib/
|
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libgd.so $(1)/usr/lib/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
$(eval $(call BuildPackage,libgd))
|
$(eval $(call BuildPackage,libgd))
|
||||||
|
|
26
libs/libgd/patches/100-no-cxx.patch
Normal file
26
libs/libgd/patches/100-no-cxx.patch
Normal file
|
@ -0,0 +1,26 @@
|
||||||
|
--- a/src/CMakeLists.txt
|
||||||
|
+++ b/src/CMakeLists.txt
|
||||||
|
@@ -23,8 +23,6 @@ SET (LIBGD_SRC_FILES
|
||||||
|
gd_io_dp.c
|
||||||
|
gd_io_file.c
|
||||||
|
gd_io_ss.c
|
||||||
|
- gd_io_stream.cxx
|
||||||
|
- gd_io_stream.h
|
||||||
|
gd_jpeg.c
|
||||||
|
gd_matrix.c
|
||||||
|
gd_nnquant.c
|
||||||
|
@@ -60,8 +58,6 @@ SET (LIBGD_SRC_FILES
|
||||||
|
gdhelpers.c
|
||||||
|
gdhelpers.h
|
||||||
|
gdkanji.c
|
||||||
|
- gdpp.cxx
|
||||||
|
- gdpp.h
|
||||||
|
gdtables.c
|
||||||
|
gdxpm.c
|
||||||
|
jisx0208.h
|
||||||
|
@@ -175,5 +171,4 @@ install(FILES
|
||||||
|
gdfonts.h
|
||||||
|
gdfontt.h
|
||||||
|
gdfx.h
|
||||||
|
- gdpp.h
|
||||||
|
DESTINATION include)
|
|
@ -1,20 +0,0 @@
|
||||||
--- a/config/gdlib-config.in
|
|
||||||
+++ b/config/gdlib-config.in
|
|
||||||
@@ -74,7 +74,7 @@ while test $# -gt 0; do
|
|
||||||
echo @LDFLAGS@
|
|
||||||
;;
|
|
||||||
--libs)
|
|
||||||
- echo -lgd @LIBS@ @LIBICONV@
|
|
||||||
+ echo -lgd @LIBS@
|
|
||||||
;;
|
|
||||||
--cflags|--includes)
|
|
||||||
echo -I@includedir@
|
|
||||||
@@ -87,7 +87,7 @@ while test $# -gt 0; do
|
|
||||||
echo "includedir: $includedir"
|
|
||||||
echo "cflags: -I@includedir@"
|
|
||||||
echo "ldflags: @LDFLAGS@"
|
|
||||||
- echo "libs: @LIBS@ @LIBICONV@"
|
|
||||||
+ echo "libs: @LIBS@"
|
|
||||||
echo "libdir: $libdir"
|
|
||||||
echo "features: @FEATURES@"
|
|
||||||
;;
|
|
|
@ -1,9 +0,0 @@
|
||||||
--- a/config/gdlib.pc.in
|
|
||||||
+++ b/config/gdlib.pc.in
|
|
||||||
@@ -7,5 +7,5 @@ Name: gd
|
|
||||||
Description: GD graphics library
|
|
||||||
Version: @VERSION@
|
|
||||||
Cflags: -I${includedir}
|
|
||||||
-Libs.private: @LIBS@ @LIBICONV@
|
|
||||||
+Libs.private: @LIBS@
|
|
||||||
Libs: -L${libdir} -lgd
|
|
|
@ -1,24 +0,0 @@
|
||||||
--- a/src/gd_bmp.c
|
|
||||||
+++ b/src/gd_bmp.c
|
|
||||||
@@ -28,6 +28,7 @@
|
|
||||||
#include <math.h>
|
|
||||||
#include <string.h>
|
|
||||||
#include <stdlib.h>
|
|
||||||
+#include <features.h>
|
|
||||||
#include "gd.h"
|
|
||||||
#include "gdhelpers.h"
|
|
||||||
#include "bmp.h"
|
|
||||||
@@ -49,6 +50,13 @@ static int bmp_read_rle(gdImagePtr im, g
|
|
||||||
|
|
||||||
#define BMP_DEBUG(s)
|
|
||||||
|
|
||||||
+#if defined(__UCLIBC__) && !defined(__UCLIBC_HAS_LONG_DOUBLE_MATH__)
|
|
||||||
+long double ceill(long double x)
|
|
||||||
+{
|
|
||||||
+ return (long double)ceil((double)x);
|
|
||||||
+}
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
static int gdBMPPutWord(gdIOCtx *out, int w)
|
|
||||||
{
|
|
||||||
/* Byte order is little-endian */
|
|
Loading…
Reference in a new issue