tgt: update to 1.0.80
- add runtime test - drop the patch that has gone upstream Signed-off-by: Maxim Storchak <m.storchak@gmail.com>
This commit is contained in:
parent
5c6a3f78a8
commit
a0af732541
3 changed files with 6 additions and 14 deletions
|
@ -4,12 +4,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=tgt
|
||||
PKG_VERSION:=1.0.79
|
||||
PKG_RELEASE:=3
|
||||
PKG_VERSION:=1.0.80
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/fujita/tgt/tar.gz/v$(PKG_VERSION)?
|
||||
PKG_HASH:=6736d799a202ff665549359859441c6d2b5e3425bffef9ee60ab5a101342a40d
|
||||
PKG_HASH:=e2255482f1a2797c115a6d545c37428b10a4ba6276a2af787da5378fa4e34e75
|
||||
|
||||
PKG_MAINTAINER:=Maxim Storchak <m.storchak@gmail.com>
|
||||
PKG_LICENSE:=GPL-2.0-only
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- a/usr/iscsi/target.c
|
||||
+++ b/usr/iscsi/target.c
|
||||
@@ -224,7 +224,7 @@ get_redirect_address(char *callback, char *buffer, int buflen,
|
||||
{
|
||||
char *p, *addr, *port;
|
||||
|
||||
- bzero(buffer, buflen);
|
||||
+ memset(buffer, 0, buflen);
|
||||
if (call_program(callback, NULL, NULL, buffer, buflen, 0))
|
||||
return -1;
|
||||
|
3
net/tgt/test.sh
Normal file
3
net/tgt/test.sh
Normal file
|
@ -0,0 +1,3 @@
|
|||
#!/bin/sh
|
||||
|
||||
tgtd -V | grep "$2"
|
Loading…
Reference in a new issue