Merge pull request #4204 from commodo/python3-upgrade
python3: upgrade to version 3.6.1
This commit is contained in:
commit
a0714019fa
4 changed files with 5 additions and 30 deletions
|
@ -14,13 +14,13 @@ PYTHON_VERSION:=$(PYTHON3_VERSION)
|
|||
PYTHON_VERSION_MICRO:=$(PYTHON3_VERSION_MICRO)
|
||||
|
||||
PKG_NAME:=python3
|
||||
PKG_RELEASE:=5
|
||||
PKG_RELEASE:=1
|
||||
PKG_VERSION:=$(PYTHON_VERSION).$(PYTHON_VERSION_MICRO)
|
||||
|
||||
PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://www.python.org/ftp/python/$(PKG_VERSION)
|
||||
PKG_MD5SUM:=82b143ebbf4514d7e05876bed7a6b1f5
|
||||
PKG_HASH:=b0c5f904f685e32d9232f7bdcbece9819a892929063b6e385414ad2dd6a23622
|
||||
PKG_MD5SUM:=692b4fc3a2ba0d54d1495d4ead5b0b5c
|
||||
PKG_HASH:=a01810ddfcec216bcdb357a84bfaafdfaa0ca42bbdaa4cb7ff74f5a9961e4041
|
||||
|
||||
PKG_LICENSE:=PSF
|
||||
PKG_LICENSE_FILES:=LICENSE Modules/_ctypes/libffi_msvc/LICENSE Modules/_ctypes/darwin/LICENSE Modules/_ctypes/libffi/LICENSE Modules/_ctypes/libffi_osx/LICENSE Tools/pybench/LICENSE
|
||||
|
|
|
@ -5,9 +5,10 @@
|
|||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
# Note: keep in sync with setuptools & pip
|
||||
PYTHON3_VERSION_MAJOR:=3
|
||||
PYTHON3_VERSION_MINOR:=6
|
||||
PYTHON3_VERSION_MICRO:=0
|
||||
PYTHON3_VERSION_MICRO:=1
|
||||
|
||||
PYTHON3_VERSION:=$(PYTHON3_VERSION_MAJOR).$(PYTHON3_VERSION_MINOR)
|
||||
|
||||
|
|
|
@ -1,14 +0,0 @@
|
|||
diff --git a/setup.py b/setup.py
|
||||
index 93f390f..ace1494 100644
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -461,7 +461,8 @@ class PyBuildExt(build_ext):
|
||||
add_dir_to_list(dir_list, directory)
|
||||
|
||||
if os.path.normpath(sys.base_prefix) != '/usr' \
|
||||
- and not sysconfig.get_config_var('PYTHONFRAMEWORK'):
|
||||
+ and not sysconfig.get_config_var('PYTHONFRAMEWORK') \
|
||||
+ and not cross_compiling:
|
||||
# OSX note: Don't add LIBDIR and INCLUDEDIR to building a framework
|
||||
# (PYTHONFRAMEWORK is set) to avoid # linking problems when
|
||||
# building a framework with different architectures than
|
|
@ -10,15 +10,3 @@ index 3bf2ca7..c156964 100644
|
|||
#ifdef __sgi
|
||||
#include <term.h>
|
||||
#endif
|
||||
diff --git a/setup.py b/setup.py
|
||||
index af9a414..ee19ecd 100644
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -1349,7 +1349,6 @@ class PyBuildExt(build_ext):
|
||||
panel_library = 'panel'
|
||||
if curses_library == 'ncursesw':
|
||||
curses_defines.append(('HAVE_NCURSESW', '1'))
|
||||
- curses_includes.append('/usr/include/ncursesw')
|
||||
# Bug 1464056: If _curses.so links with ncursesw,
|
||||
# _curses_panel.so must link with panelw.
|
||||
panel_library = 'panelw'
|
||||
|
|
Loading…
Reference in a new issue