stubby: bump to 0.4.0
Remove obsolete patch. Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
This commit is contained in:
parent
0261cd0972
commit
a01696890c
2 changed files with 2 additions and 37 deletions
|
@ -5,13 +5,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=stubby
|
||||
PKG_VERSION:=0.3.0
|
||||
PKG_VERSION:=0.4.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://github.com/getdnsapi/$(PKG_NAME)
|
||||
PKG_SOURCE_VERSION:=v$(PKG_VERSION)
|
||||
PKG_MIRROR_HASH:=f1585aa6881bf39c2c8f99df045d5739bb78403417a1e827644cb202fa4280f0
|
||||
PKG_MIRROR_HASH:=bc5f604da1b70287a6c3d89eac2e13ce8bca52840e7b72ab098a3deeb9935082
|
||||
|
||||
PKG_MAINTAINER:=Jonathan Underwood <jonathan.underwood@gmail.com>
|
||||
PKG_LICENSE:=BSD-3-Clause
|
||||
|
|
|
@ -1,35 +0,0 @@
|
|||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -115,14 +115,26 @@ install(FILES AUTHORS COPYING ChangeLog
|
||||
|
||||
# Ensure the file gets CRLF line endings on Windows.
|
||||
file(GENERATE OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/stubby.yml INPUT ${CMAKE_CURRENT_SOURCE_DIR}/stubby.yml.example)
|
||||
-# Copy to destination iff no destination file exists.
|
||||
+
|
||||
+# Copy stubby.yml to destination iff no destination file exists.
|
||||
+# This is complicated by (a) not being able to use generators, due to
|
||||
+# CMake minimum version requirement, and (b) to account for DESTDIR.
|
||||
+# And in the latter case, if we're adding DESTDIR to the start of the
|
||||
+# path, we must on Windows remove any initial drive letter. That's what
|
||||
+# INSTALL appears to do.
|
||||
install(CODE "\
|
||||
- set(targetdir ${STUBBYCONFDIR})\n\
|
||||
- if (\$ENV{DESTDIR})\n\
|
||||
- set(targetdir \$ENV{DESTDIR}/\${targetdir})\n\
|
||||
+ set(targetdir \"${STUBBYCONFDIR}\")\n\
|
||||
+ set(destdir \"\$ENV{DESTDIR}\")\n\
|
||||
+ if (destdir)\n\
|
||||
+ string(REGEX REPLACE \"^([A-Z]:)?/(.*)\" \"\\\\2\" newtarget \"\${targetdir}\")\n\
|
||||
+ if (newtarget)\n\
|
||||
+ set(targetdir \"\${newtarget}\")\n\
|
||||
+ endif ()\n\
|
||||
+ set(targetdir \"\${destdir}/\${newtarget}\")\n\
|
||||
endif ()\n\
|
||||
- if (NOT EXISTS \${targetdir}/stubby.yml)\n\
|
||||
- file(COPY ${CMAKE_CURRENT_BINARY_DIR}/stubby.yml DESTINATION \${targetdir})\n\
|
||||
+ if (NOT EXISTS \"\${targetdir}/stubby.yml\")\n\
|
||||
+ file(COPY \"${CMAKE_CURRENT_BINARY_DIR}/stubby.yml\" DESTINATION \"\${targetdir}\")\n\
|
||||
+ message(\"-- Installing: \${targetdir}/stubby.yml\")\n\
|
||||
endif ()")
|
||||
|
||||
if (APPLE)
|
Loading…
Reference in a new issue