conmon: update to 2.0.29
Patch fixing segfaults on nulls was removed due to patch's content being now included in conmon's source since containers/conmon@355dbf1 Signed-off-by: Oskari Rauta <oskari.rauta@gmail.com>
This commit is contained in:
parent
3ba2a3411d
commit
9fdfe2e2c7
2 changed files with 3 additions and 25 deletions
|
@ -1,14 +1,14 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=conmon
|
PKG_NAME:=conmon
|
||||||
PKG_VERSION:=2.0.27
|
PKG_VERSION:=2.0.29
|
||||||
PKG_RELEASE:=$(AUTORELEASE)
|
PKG_RELEASE:=$(AUTORELEASE)
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://github.com/containers/$(PKG_NAME)/archive/v$(PKG_VERSION)
|
PKG_SOURCE_URL:=https://github.com/containers/$(PKG_NAME)/archive/v$(PKG_VERSION)
|
||||||
PKG_HASH:=cb953fa418835a3f57af175df3641140d9c44ec219a7ad2efcc07952241f9ea5
|
PKG_HASH:=eb4d5e157671a61b88786e44094775194e30e1d0ad0b9d50035532ece78dbc28
|
||||||
|
|
||||||
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
|
PKG_MAINTAINER:=Oskari Rauta <oskari.rauta@gmail.com>
|
||||||
PKG_LICENSE:=Apache-2.0
|
PKG_LICENSE:=Apache-2.0
|
||||||
PKG_LICENSE_FILES:=LICENSE
|
PKG_LICENSE_FILES:=LICENSE
|
||||||
|
|
||||||
|
|
|
@ -1,22 +0,0 @@
|
||||||
--- a/src/conn_sock.c
|
|
||||||
+++ b/src/conn_sock.c
|
|
||||||
@@ -465,6 +465,9 @@ static void init_remote_sock(struct remo
|
|
||||||
|
|
||||||
static void close_sock(gpointer data, G_GNUC_UNUSED gpointer user_data)
|
|
||||||
{
|
|
||||||
+ if (data == NULL)
|
|
||||||
+ return;
|
|
||||||
+
|
|
||||||
struct remote_sock_s *sock = (struct remote_sock_s *)data;
|
|
||||||
|
|
||||||
close(sock->fd);
|
|
||||||
@@ -473,5 +476,9 @@ static void close_sock(gpointer data, G_
|
|
||||||
|
|
||||||
void close_all_readers()
|
|
||||||
{
|
|
||||||
+
|
|
||||||
+ if (local_mainfd_stdin.readers == NULL)
|
|
||||||
+ return;
|
|
||||||
+
|
|
||||||
g_ptr_array_foreach(local_mainfd_stdin.readers, close_sock, NULL);
|
|
||||||
}
|
|
Loading…
Reference in a new issue