php7: update to 7.2.1
Remove a patch which was included upstream. While at, also add openssl configuration parameters when modules are selected which depend on openssl (reported by Philip Prindeville). Signed-off-by: Michael Heimpold <mhei@heimpold.de>
This commit is contained in:
parent
b34cd50cdc
commit
9f4b18c757
2 changed files with 3 additions and 38 deletions
|
@ -6,7 +6,7 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=php
|
||||
PKG_VERSION:=7.2.0
|
||||
PKG_VERSION:=7.2.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
|
||||
|
@ -16,7 +16,7 @@ PKG_LICENSE_FILES:=LICENSE
|
|||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=http://www.php.net/distributions/
|
||||
PKG_HASH:=87572a6b924670a5d4aac276aaa4a94321936283df391d702c845ffc112db095
|
||||
PKG_HASH:=6c6cf82fda6660ed963821eb0525214bb3547e8e29f447b9c15b2d8e6efd8822
|
||||
|
||||
PKG_FIXUP:=libtool autoreconf
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
@ -301,7 +301,7 @@ else
|
|||
CONFIGURE_ARGS+= --disable-opcache
|
||||
endif
|
||||
|
||||
ifneq ($(SDK)$(CONFIG_PACKAGE_php7-mod-openssl)$(CONFIG_PACKAGE_php7-mod-snmp),)
|
||||
ifneq ($(SDK)$(CONFIG_PACKAGE_php7-mod-openssl)$(CONFIG_PACKAGE_php7-mod-ftp)$(CONFIG_PACKAGE_php7-mod-imap)$(CONFIG_PACKAGE_php7-mod-snmp),)
|
||||
CONFIGURE_ARGS+= \
|
||||
--with-openssl=shared,"$(STAGING_DIR)/usr" \
|
||||
--with-kerberos=no \
|
||||
|
|
|
@ -1,35 +0,0 @@
|
|||
From 96465be0f4ac225cfe6f52b809c91b9496807eac Mon Sep 17 00:00:00 2001
|
||||
From: Michael Heimpold <mhei@heimpold.de>
|
||||
Date: Sun, 26 Nov 2017 18:29:42 +0100
|
||||
Subject: [PATCH] ext/imap/config.m4: fix ac_cv_u8t_decompose check
|
||||
|
||||
Once upon the time, commit c58f63a38ae19caaab339c61486fc3bd7e5894f9
|
||||
changed the check from U8T_CANONICAL to U8T_DECOMPOSE. However,
|
||||
the autoconf cache id was not renamed.
|
||||
|
||||
Sometimes it is desirable to preseed the autoconf variables, e.g. when
|
||||
cross-compiling to avoid the tests running on the host system. In this
|
||||
case it's confusing when the cache id does not match the variable to
|
||||
set, so let's adjust it.
|
||||
|
||||
Signed-off-by: Michael Heimpold <mhei@heimpold.de>
|
||||
---
|
||||
ext/imap/config.m4 | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/ext/imap/config.m4 b/ext/imap/config.m4
|
||||
index d0b86cb..badb6e2 100644
|
||||
--- a/ext/imap/config.m4
|
||||
+++ b/ext/imap/config.m4
|
||||
@@ -147,7 +147,7 @@ if test "$PHP_IMAP" != "no"; then
|
||||
|
||||
old_CFLAGS=$CFLAGS
|
||||
CFLAGS="-I$IMAP_INC_DIR"
|
||||
- AC_CACHE_CHECK(for U8T_DECOMPOSE, ac_cv_u8t_canonical,
|
||||
+ AC_CACHE_CHECK(for U8T_DECOMPOSE, ac_cv_u8t_decompose,
|
||||
AC_TRY_COMPILE([
|
||||
#include <c-client.h>
|
||||
],[
|
||||
--
|
||||
2.7.4
|
||||
|
Loading…
Reference in a new issue