liblz4: add patch removing distutils requirement
Allows meson to compile on systems that lack distutils.
Signed-off-by: Rosen Penev <rosenp@gmail.com>
(cherry picked from commit cb44cd60c4
)
This commit is contained in:
parent
5f22b6c381
commit
9d03a1ea50
2 changed files with 14 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=liblz4
|
||||
PKG_VERSION:=1.9.2
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/lz4/lz4/tar.gz/v$(PKG_VERSION)?
|
||||
|
|
13
libs/liblz4/patches/020-distutils.patch
Normal file
13
libs/liblz4/patches/020-distutils.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- a/contrib/meson/meson.build
|
||||
+++ b/contrib/meson/meson.build
|
||||
@@ -35,8 +35,8 @@ compiler_msvc = 'msvc'
|
||||
lz4_version = meson.project_version()
|
||||
|
||||
lz4_h_file = join_paths(meson.current_source_dir(), '../../lib/lz4.h')
|
||||
-GetLz4LibraryVersion_py = files('GetLz4LibraryVersion.py')
|
||||
-r = run_command(python3, GetLz4LibraryVersion_py, lz4_h_file)
|
||||
+GetLz4LibraryVersion_py = find_program('GetLz4LibraryVersion.py', native : true)
|
||||
+r = run_command(GetLz4LibraryVersion_py, lz4_h_file)
|
||||
if r.returncode() == 0
|
||||
lz4_version = r.stdout().strip()
|
||||
message('Project version is now: @0@'.format(lz4_version))
|
Loading…
Reference in a new issue