hplip: bump to 3.19.12
Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
This commit is contained in:
parent
1858cb5ff5
commit
9c901e1bd1
3 changed files with 9 additions and 10 deletions
|
@ -9,12 +9,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=hplip
|
PKG_NAME:=hplip
|
||||||
PKG_VERSION:=3.19.6
|
PKG_VERSION:=3.19.12
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=@SF/hplip
|
PKG_SOURCE_URL:=@SF/hplip
|
||||||
PKG_HASH:=fcdaedee9ed17d2e70f3aff9558a452d99443d1b93d6623132faf3f3ae61d66d
|
PKG_HASH:=b7f398502fb659e0de8e54976237e3c6a64fec0b3c36054a515876f7b006b255
|
||||||
|
|
||||||
PKG_MAINTAINER:=Luiz Angelo Daros de Luca <luizluca@gmail.com>
|
PKG_MAINTAINER:=Luiz Angelo Daros de Luca <luizluca@gmail.com>
|
||||||
PKG_LICENSE:=GPL-2.0 GPL-2.0-or-later
|
PKG_LICENSE:=GPL-2.0 GPL-2.0-or-later
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/configure.in
|
--- a/configure.in
|
||||||
+++ b/configure.in
|
+++ b/configure.in
|
||||||
@@ -598,6 +598,10 @@ if test "$class_driver" = "no" && test "$hpijs_only_build" = "no" && test "$hpcu
|
@@ -601,6 +601,10 @@ if test "$class_driver" = "no" && test "
|
||||||
else
|
else
|
||||||
AC_CHECK_LIB([usb-1.0], [libusb_init], [LIBS="$LIBS"], [AC_MSG_ERROR([cannot find libusb 1.0 support], 2)])
|
AC_CHECK_LIB([usb-1.0], [libusb_init], [LIBS="$LIBS"], [AC_MSG_ERROR([cannot find libusb 1.0 support], 2)])
|
||||||
AC_CHECK_HEADERS(libusb-1.0/libusb.h, ,[AC_MSG_ERROR([cannot find libusb-1.0-devel support], 11)])
|
AC_CHECK_HEADERS(libusb-1.0/libusb.h, ,[AC_MSG_ERROR([cannot find libusb-1.0-devel support], 11)])
|
||||||
|
|
|
@ -19,7 +19,7 @@
|
||||||
#include "hpmud.h"
|
#include "hpmud.h"
|
||||||
#include "hp_ipp.h"
|
#include "hp_ipp.h"
|
||||||
#include "soap.h"
|
#include "soap.h"
|
||||||
@@ -145,98 +144,6 @@ static int GetUriLine(char *buf, char *uri, char **tail)
|
@@ -145,98 +144,6 @@ static int GetUriLine(char *buf, char *u
|
||||||
return i;
|
return i;
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -126,13 +126,13 @@
|
||||||
char* token = NULL;
|
char* token = NULL;
|
||||||
enum HPMUD_RESULT stat;
|
enum HPMUD_RESULT stat;
|
||||||
|
|
||||||
@@ -304,34 +210,6 @@ static int DevDiscovery(int localOnly)
|
@@ -304,33 +210,6 @@ static int DevDiscovery(int localOnly)
|
||||||
total += AddDevice(uri);
|
total += AddDevice(uri);
|
||||||
}
|
}
|
||||||
|
memset(message, 0, sizeof(message));
|
||||||
- /* Look for Network Scan devices if localonly flag if FALSE. */
|
- /* Look for Network Scan devices if localonly flag if FALSE. */
|
||||||
- if (!localOnly)
|
- if (!localOnly)
|
||||||
- {
|
- {
|
||||||
- /* Look for all-in-one scan devices for which print queue created */
|
- /* Look for all-in-one scan devices for which print queue created */
|
||||||
- cnt = GetCupsPrinters(&cups_printer);
|
- cnt = GetCupsPrinters(&cups_printer);
|
||||||
- for (i=0; i<cnt; i++)
|
- for (i=0; i<cnt; i++)
|
||||||
|
@ -157,7 +157,6 @@
|
||||||
- SendScanEvent("hpaio:/net/HP_Scan_Devices?ip=1.1.1.1", EVENT_ERROR_NO_PROBED_DEVICES_FOUND);
|
- SendScanEvent("hpaio:/net/HP_Scan_Devices?ip=1.1.1.1", EVENT_ERROR_NO_PROBED_DEVICES_FOUND);
|
||||||
- }
|
- }
|
||||||
- }
|
- }
|
||||||
-
|
|
||||||
bugout:
|
bugout:
|
||||||
return total;
|
return total;
|
||||||
}
|
|
||||||
|
|
Loading…
Reference in a new issue