libshout: Update to 2.4.3
Removed inactive maintainer. Rearranged Makefile for consistency between packages. Added --without-pic to avoid both -fPIC and -fpic. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
8897ea4d51
commit
9bacdfa9a2
4 changed files with 13 additions and 52 deletions
|
@ -6,21 +6,21 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libshout
|
||||
PKG_VERSION:=2.4.1
|
||||
PKG_RELEASE:=3
|
||||
PKG_VERSION:=2.4.3
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://downloads.us.xiph.org/releases/libshout/
|
||||
PKG_HASH:=f3acb8dec26f2dbf6df778888e0e429a4ce9378a9d461b02a7ccbf2991bbf24d
|
||||
PKG_SOURCE_URL:=https://downloads.us.xiph.org/releases/libshout/
|
||||
PKG_HASH:=0d8af55d1141bf90710bcd41a768c9cc5adb251502a0af1dd22c8da215d40dfe
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
|
||||
PKG_LICENSE:=LGPL-2.0+
|
||||
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
|
||||
PKG_LICENSE:=LGPL-2.0-or-later
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
PKG_MAINTAINER:=Nicolas Thill <nico@openwrt.org>, \
|
||||
Ted Hess <thess@kitschensync.net>
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
|
@ -77,21 +77,22 @@ Package/libshout-full/description=$(Package/libshout/description/default)
|
|||
CONFIGURE_ARGS += \
|
||||
--enable-shared \
|
||||
--enable-static \
|
||||
--disable-speex
|
||||
--disable-speex \
|
||||
--without-pic
|
||||
|
||||
ifeq ($(BUILD_VARIANT),notheora)
|
||||
CONFIGURE_ARGS += --disable-theora
|
||||
endif
|
||||
|
||||
ifeq ($(BUILD_VARIANT),nossl)
|
||||
CONFIGURE_ARGS += --disable-theora --with-openssl="no"
|
||||
CONFIGURE_ARGS += --disable-theora --without-openssl
|
||||
endif
|
||||
|
||||
CONFIGURE_VARS += \
|
||||
VORBIS_CFLAGS="-I$(STAGING_DIR)/usr/include/tremor/" \
|
||||
VORBIS_LIBS="$(TARGET_LDFLAGS) -lvorbisidec" \
|
||||
|
||||
TARGET_CFLAGS += $(FPIC) -Wl,-rpath-link="$(STAGING_DIR)/usr/lib"
|
||||
TARGET_CFLAGS += $(FPIC)
|
||||
|
||||
PACKAGE_CONFIG_FILE=shout$(if $(findstring $(BUILD_VARIANT),full),-full).pc
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/src/codec_vorbis.c
|
||||
+++ b/src/codec_vorbis.c
|
||||
@@ -28,7 +28,7 @@
|
||||
@@ -29,7 +29,7 @@
|
||||
#endif
|
||||
#include <stdlib.h>
|
||||
|
||||
|
|
|
@ -1,19 +0,0 @@
|
|||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -3,14 +3,14 @@
|
||||
AUTOMAKE_OPTIONS = 1.6 foreign
|
||||
ACLOCAL_AMFLAGS = -I m4
|
||||
|
||||
-SUBDIRS = include src examples doc win32
|
||||
+SUBDIRS = include src
|
||||
|
||||
EXTRA_DIST = INSTALL m4/shout.m4 m4/acx_pthread.m4 \
|
||||
m4/ogg.m4 m4/vorbis.m4 m4/xiph_compiler.m4 m4/xiph_net.m4 \
|
||||
m4/xiph_types.m4 libshout.ckport
|
||||
|
||||
docdir = $(datadir)/doc/$(PACKAGE)
|
||||
-doc_DATA = COPYING NEWS README examples/example.c examples/nonblocking.c
|
||||
+doc_DATA = COPYING README
|
||||
|
||||
m4datadir = $(datadir)/aclocal
|
||||
m4data_DATA = m4/shout.m4
|
|
@ -1,21 +0,0 @@
|
|||
diff --git a/src/tls.c b/src/tls.c
|
||||
index 4562c73..f946946 100644
|
||||
--- a/src/tls.c
|
||||
+++ b/src/tls.c
|
||||
@@ -63,12 +63,16 @@ static inline int tls_setup(shout_tls_t *tls)
|
||||
{
|
||||
SSL_METHOD *meth;
|
||||
|
||||
+#if OPENSSL_VERSION_NUMBER < 0x10100000L
|
||||
SSL_library_init();
|
||||
SSL_load_error_strings();
|
||||
SSLeay_add_all_algorithms();
|
||||
SSLeay_add_ssl_algorithms();
|
||||
|
||||
meth = TLSv1_client_method();
|
||||
+#else
|
||||
+ meth = TLS_client_method();
|
||||
+#endif
|
||||
if (!meth)
|
||||
goto error;
|
||||
|
Loading…
Reference in a new issue