From 9b94e3cb6eab07e6ba44ca74ea5ffc19f39d0bd7 Mon Sep 17 00:00:00 2001
From: Alexandru Ardelean <aa@ocedo.com>
Date: Tue, 6 Jan 2015 10:48:52 +0200
Subject: [PATCH] python: trim all whitespaces for the operator in the filespec

That would allow for files (in filespecs) to be indented.
As it is now, the files need to be added at the begginning of the line.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
---
 lang/python/files/python-package.mk | 1 +
 1 file changed, 1 insertion(+)

diff --git a/lang/python/files/python-package.mk b/lang/python/files/python-package.mk
index 9a999d4f0..71d500d1d 100644
--- a/lang/python/files/python-package.mk
+++ b/lang/python/files/python-package.mk
@@ -45,6 +45,7 @@ define PyPackage
 	@echo "$$$$$$$$$$(call shvar,PyPackage/$(1)/filespec)" | ( \
 		IFS='|'; \
 		while read fop fspec fperm; do \
+		  fop=`echo "$$$$$$$$fop" | tr -d ' \t\n'`; \
 		  if [ "$$$$$$$$fop" = "+" ]; then \
 			if [ ! -e "$(PKG_INSTALL_DIR)$$$$$$$$fspec" ]; then \
 			  echo "File not found '$(PKG_INSTALL_DIR)$$$$$$$$fspec'"; \