mjpg-streamer: update to last upstream version
Changes: Update patches Add listen_ip option to config Signed-off-by: Jan Pavlinec <jan.pavlinec@nic.cz>
This commit is contained in:
parent
6c5f68ad14
commit
9b56b1e939
5 changed files with 16 additions and 11 deletions
|
@ -6,17 +6,17 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=mjpg-streamer
|
||||
PKG_VERSION:=2018-04-14
|
||||
PKG_VERSION:=2018-10-25
|
||||
PKG_RELEASE:=1
|
||||
PKG_MAINTAINER:=Roger D <rogerdammit@gmail.com>, \
|
||||
Ted Hess <thess@kitschensync.net>
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://github.com/jacksonliam/mjpg-streamer.git
|
||||
PKG_SOURCE_VERSION:=821c330ea6bbb5fbed98d48e00aac156e923161b
|
||||
PKG_SOURCE_VERSION:=ddb69b7b4f114f3c2ca01adf55712792ca8aed43
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_MIRROR_HASH:=f95e54bc95c808b9867bbca364e58b6c7e08cb26613205f8d87450ab9c899942
|
||||
PKG_MIRROR_HASH:=d87ebff5de0c17a35a5b81adad5aa234bc70fe2bb17d1c6277c726845dc043bb
|
||||
|
||||
PKG_LICENSE:=GPL-2.0
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
|
|
|
@ -11,5 +11,6 @@ config mjpg-streamer 'core'
|
|||
option led 'auto'
|
||||
option www '/www/webcam'
|
||||
option port '8080'
|
||||
#option listen_ip '192.168.1.1'
|
||||
option username 'openwrt'
|
||||
option password 'openwrt'
|
||||
|
|
|
@ -69,6 +69,9 @@ start_instance() {
|
|||
config_get port "$s" 'port'
|
||||
[ -n "$port" ] && output_arg="${output_arg} --port $port"
|
||||
|
||||
config_get listen_ip "$s" 'listen_ip'
|
||||
[ -n "$listen_ip" ] && output_arg="${output_arg} --listen $listen_ip"
|
||||
|
||||
config_get www "$s" 'www'
|
||||
[ -n "$www" ] && output_arg="${output_arg} --www $www"
|
||||
|
||||
|
|
|
@ -19,6 +19,7 @@
|
|||
add_subdirectory(plugins/output_udp)
|
||||
-add_subdirectory(plugins/output_viewer)
|
||||
+#add_subdirectory(plugins/output_viewer)
|
||||
add_subdirectory(plugins/output_zmqserver)
|
||||
|
||||
#
|
||||
# mjpg_streamer executable
|
||||
|
|
|
@ -12,18 +12,18 @@
|
|||
# Input plugins
|
||||
--- a/plugins/input_uvc/CMakeLists.txt
|
||||
+++ b/plugins/input_uvc/CMakeLists.txt
|
||||
@@ -8,27 +8,27 @@ if (PLUGIN_INPUT_UVC)
|
||||
|
||||
@@ -9,27 +9,27 @@ if (PLUGIN_INPUT_UVC)
|
||||
add_definitions(-DLINUX -D_GNU_SOURCE)
|
||||
|
||||
- find_library(V4L2_LIB v4l2)
|
||||
+# find_library(V4L2_LIB v4l2)
|
||||
find_library(V4L2_LIB v4l2)
|
||||
- find_library(JPEG_LIB jpeg)
|
||||
+# find_library(JPEG_LIB jpeg)
|
||||
|
||||
- if (V4L2_LIB)
|
||||
- add_definitions(-DUSE_LIBV4L2)
|
||||
- endif (V4L2_LIB)
|
||||
+# if (V4L2_LIB)
|
||||
+# add_definitions(-DUSE_LIBV4L2)
|
||||
+# add_definitions(-DUSE_LIBV4L2)
|
||||
+# endif (V4L2_LIB)
|
||||
|
||||
- if (NOT JPEG_LIB)
|
||||
|
|
Loading…
Reference in a new issue