pdns-recursor: update to 4.5.2
Signed-off-by: Peter van Dijk <peter.van.dijk@powerdns.com>
This commit is contained in:
parent
5ad56ca340
commit
9aa1d773c7
3 changed files with 19 additions and 10 deletions
|
@ -1,12 +1,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=pdns-recursor
|
PKG_NAME:=pdns-recursor
|
||||||
PKG_VERSION:=4.4.2
|
PKG_VERSION:=4.5.2
|
||||||
PKG_RELEASE:=$(AUTORELEASE)
|
PKG_RELEASE:=$(AUTORELEASE)
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=https://downloads.powerdns.com/releases/
|
PKG_SOURCE_URL:=https://downloads.powerdns.com/releases/
|
||||||
PKG_HASH:=b0b97f49848a1758b64bc0b99a596c1583ea525477193f3c01905f5163a4f5cf
|
PKG_HASH:=b1283d5354f1cbb3d15791f96af3ab3e08a13453431e94fe87b8dbe9f78f0184
|
||||||
|
|
||||||
PKG_MAINTAINER:=Peter van Dijk <peter.van.dijk@powerdns.com>
|
PKG_MAINTAINER:=Peter van Dijk <peter.van.dijk@powerdns.com>
|
||||||
PKG_LICENCE:=GPL-2.0-only
|
PKG_LICENCE:=GPL-2.0-only
|
||||||
|
@ -16,7 +16,6 @@ PKG_CPE_ID:=cpe:/a:powerdns:recursor
|
||||||
PKG_FIXUP:=autoreconf
|
PKG_FIXUP:=autoreconf
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
PKG_BUILD_PARALLEL:=1
|
PKG_BUILD_PARALLEL:=1
|
||||||
PKG_BUILD_DEPENDS:=protobuf/host
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
@ -26,7 +25,7 @@ define Package/pdns-recursor
|
||||||
SUBMENU:=IP Addresses and Names
|
SUBMENU:=IP Addresses and Names
|
||||||
USERID:=pdns:pdns
|
USERID:=pdns:pdns
|
||||||
TITLE:=PowerDNS Recursor
|
TITLE:=PowerDNS Recursor
|
||||||
DEPENDS:=+boost +boost-context +boost-filesystem +libatomic +liblua +libopenssl +protobuf +libfstrm
|
DEPENDS:=+boost +boost-context +boost-filesystem +libatomic +liblua +libopenssl +libfstrm
|
||||||
URL:=https://www.powerdns.com/recursor.html
|
URL:=https://www.powerdns.com/recursor.html
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
@ -40,20 +39,19 @@ define Package/pdns-recursor/conffiles
|
||||||
/etc/init.d/pdns-recursor
|
/etc/init.d/pdns-recursor
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
# not everything groks --disable-nls
|
||||||
|
DISABLE_NLS:=
|
||||||
|
|
||||||
CONFIGURE_ARGS += \
|
CONFIGURE_ARGS += \
|
||||||
|
--enable-option-checking=fatal \
|
||||||
--sysconfdir=/etc/powerdns \
|
--sysconfdir=/etc/powerdns \
|
||||||
--with-lua=lua \
|
--with-lua=lua \
|
||||||
--without-libcap \
|
--without-libcap \
|
||||||
--without-libsodium \
|
--without-libsodium \
|
||||||
--with-protobuf \
|
|
||||||
--without-net-snmp \
|
--without-net-snmp \
|
||||||
--enable-reproducible \
|
--enable-reproducible \
|
||||||
--disable-silent-rules
|
--disable-silent-rules
|
||||||
|
|
||||||
CONFIGURE_VARS += \
|
|
||||||
boost_cv_lib_context=yes \
|
|
||||||
boost_cv_lib_context_LIBS=-lboost_context
|
|
||||||
|
|
||||||
define Package/pdns-recursor/install
|
define Package/pdns-recursor/install
|
||||||
$(INSTALL_DIR) $(1)/etc/powerdns
|
$(INSTALL_DIR) $(1)/etc/powerdns
|
||||||
$(INSTALL_CONF) ./files/recursor.conf-dist $(1)/etc/powerdns/
|
$(INSTALL_CONF) ./files/recursor.conf-dist $(1)/etc/powerdns/
|
||||||
|
|
11
net/pdns-recursor/patches/010-time_t-check.patch
Normal file
11
net/pdns-recursor/patches/010-time_t-check.patch
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -25,8 +25,6 @@ AC_PROG_CC
|
||||||
|
AC_PROG_CXX
|
||||||
|
AC_LANG([C++])
|
||||||
|
|
||||||
|
-PDNS_CHECK_TIME_T
|
||||||
|
-
|
||||||
|
AC_DEFINE([RECURSOR], [1],
|
||||||
|
[This is the PowerDNS Recursor]
|
||||||
|
)
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/Makefile.am
|
--- a/Makefile.am
|
||||||
+++ b/Makefile.am
|
+++ b/Makefile.am
|
||||||
@@ -452,12 +452,6 @@ $(srcdir)/effective_tld_names.dat:
|
@@ -433,12 +433,6 @@ $(srcdir)/effective_tld_names.dat:
|
||||||
pubsuffix.cc: $(srcdir)/effective_tld_names.dat
|
pubsuffix.cc: $(srcdir)/effective_tld_names.dat
|
||||||
$(AM_V_GEN)./mkpubsuffixcc
|
$(AM_V_GEN)./mkpubsuffixcc
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue